Ostad Online :: Training on the Web

لينكهاي روزانه

جديدترين نرم افزار macromedia

در خبرنامه استاد آن لاين عضو شويد

بازديد كنندگان

مركز اطلاع رساني و تكنولوژي اطلاعات اصفهان (I.T )

افزايش روز افزون قابليتهاي كامپيوترهاي شخصي ، تلفنهاي همراه ، توسعه ماهواره ها ، كابلها و ديگر شبكه ها ، فرمهاي جديدي از توزيع جهاني را پايدار ساخته اند كه از طريق آن محصولات و خدمات رسانه هاي نوشتاري ، سمعي و بصري و دخول آنها در روندي كامل به سوي صنعت ، توسط پيشرفتهاي بزرگ در تكنولوژي به سوي وسعتي پهناور كشيده شده است كه اصطلاح همگرايي براي آن كاربرد بسياري دارد . اين همگرايي بر اساس نوآوريهاي فني در علوم ميكروالكترونيك و كامپيوترها و ارتباط دوربرد بنيان نهاده شده است . تمامي انواع داده ها از طريق ديجيتالي شدن، براساس معمول ترين ساختار اطلاعاتي شان تكميل و اداره مي شوند. علاوه بر اين ، توسعه تكنولوژي ماهواره و فيبر نوري ، امكان انتقال سريع اطلاعات فراواني را در هر ثانيه فراهم مي سازد ، افزايش ظرفيت ريز تراشه ها نيز براي ارتباط داده ها و تكميل انواع مختلف ارتباطات الكترونيكي كارايي فراواني دارد . كامپيوتر و مودم به ديگر نرم افزارهاي جديد كمك كرده اند تا در بالاتربن رده پيشرفت در تاريخ ارتباطات بشري كه اغلب (( جامعه اطلاعات )) ناميده مي شود، قرار گيريم و روش كار مردان و زنان بسياري را در صنايع رسانه هاي نوشتاري ، سمعي و بصري تغيير دهيم .

شالوده اين شاهراه اطلاعاتي سالياني قبل ريخته شده است . زيرا شالوده آن سيستم كلي تلويزيون ، راديو ، تلگراف ، ماهواره و شبكه هاي كامپيوتري ، سيستمهاي ديجيتالي سيستم شبكه هاي راديويي سيار و سيستمهاي ديگري كه اطلاعات ، داده ها، تصاوير و صدا ها را انتقال مي دهند ، مي باشد . روزانه ، ميزان قابل توجهي متن ، صدا و تصاوير شامل فيلمها ، برنامه هاي راديويي و تلويزيوني در سراسر جهان توسط افراد دريافت ، ذخيره ، پردازش ، نمايش و ارسال مي شود .

تاثير تكنولوژيهاي ارتباطات ، اطلاعات ، عوامل مربوطه و بازده فرآيند آن ، بر روي تعداد و ساختار نيروي كار اثر گذاشته و موقعيتهاي كاري و الگوهاي حرفه اي را تغيير داده است . تكنولوژيها بر روي وضعيت كارگران به خصوص در سالهاي اخير موثر بوده و به ندرت شغلي يافت مي شود كه تحت تاثير آن قرار نگرفته باشد . نياز به ساختار مدرن علم ارتباط از راه دور و ضرورت توسعه علم ارتباطات و اطلاع رساني منجر به كوشش مستمر اداره كل آموزش فني و حرفه اي استان اصفهان در ايجاد مركز اطلاع رساني و تكنولوژي اطلاعات گرديد .

مركز اطلاع رساني و تكنولوژي اطلاعات اصفهان ،‌به عنوان اولين و بزرگترين مركز تحقيقات و آموزش تكنولوژي اطلاعات استان اصفهان ، با مجهز ترين امكانات رايانه اي و استفاده از كادر مجرب و متعهد ، همچنين با رعايت سطح بالاي استاندارد هاي جهاني در تكنولوژي اطلاعات در بهمن ماه 1379 آغاز به كار نمود . هم اكنون با ارائه رشته هاي متنوع آموزشي در زمينه تكنولوژي اطلاعات ، اطلاع رساني و خدمات پژوهشي ، اطلاع رساني و اينترنت در اين مركز به اميد برداشتن گامهايي بلندتر مي باشيم كه پشتيباني علمي و معنوي هموطنان ، چراغ راه است و بدينوسيله خداوند را سپاس مي گوييم .

كليه حقوق اين سايت متعلق به مركز تحقيقات فناوري و آموزش مي باشد. - طراحي : واحد اموزش مجازي


لينكهاي روزانه

جديدترين نرم افزار macromedia

در خبرنامه استاد آن لاين عضو شويد

بازديد كنندگان

دريافت مدرك

کاربر گرامی :

از آنجا که پايه و اساس بستر مخابراتی و شرایط کیفی خطو ط کاربران اینترنت اجازه امکان برگزاری آزمون همزمان از راه دور را فراهم نمی آورد ، کاربرانی که نمره بالای 75 در آزمون روی وب در هر دوره کسب می نمایند در صورت علاقه مندی می توانند در آزمون حضوری دوره مربوطه در مرکز اطلاع رسانی و تکنولوژی اطلاعات اصفهان شرکت نموده و مدرک مربوط به دوره آموزشی را کسب نمایند .

هفتمين آزمون سراسری سایت استاد آن لاین نیز با کاربرانی که از راههای دور و نزدیک برای شرکت در آزمون حضوری و اخذ مدرک طلایی ممهور به مهر IT گرد هم آمده بودند در مرکز تکنولوژی اطلاعات اصفهان برگزار شد. هشتمين آزمون سراسری عملی این سایت در تاریخ 26 آبان ماه 1384 انجام می گردد،لذا از خانمها و آقایانی که در این مدت توسط پست الکترونیک با آنها مکاتبه خواهد شد دعوت می شود، راس ساعت 9 صبح با در دست داشتن کارت شناسایی معتبر عکس دار ، يك برگ فتوكپي شناسنامه و به ازاي هر دوره ي آموزشي كه حدنصاب لازم را كسب نموده اند يك قطعه عكس ، به پذیرش مرکز اطلاع رسانی و تکنولوژی اطلاعات اصفهان مراجعه نمایند.بدیهی است عدم حضور شما در تاریخ مقرر به منزله انصراف تلقی می گردد.

توجه :

ü از كاربران محترم خواهشمنديم بدليل خوانايي بيشتر نام و نام خانوادگي ، مشخصات خود را بصورت لاتين وارد نماييد .

ü کاربران محترم به دليل ارسال E-mail هاي گروهي ، سايت Yahoo ، مكاتبات الكترونيكي استاد آن لاين را در صندوق Bulk شما ذخيره مي نمايد . خواهشمنديم در صورت عضويت در سايت Yahoo و شركت در آزمون استاد آن لاين پاسخ مكاتبات خود را در صندوق bulk خود پيگيري فرماييد .

گروه تخصصی آموزش مجازی (ostadonline)


New Page 1

پيش از شروع آموزش اينجا را كليك كنيد ● كار آموزان برتر سايت استاد آن لاين ● آموزش الكترونيكي در آموزشهاي فني و حرفه اي

نام دوره آموزشی | مدرس
آموزش اینترنت - مهارت هفتم از ICDL | بيتا ضرابيان
آموزش فتوشاپ | فاطمه حسني
آموزش HTML | بيتا ضرابيان
آموزش مباحث پيشرفته در طراحي صفحات وبjavascript - SQL - ADO | نوشين ابراهيم زاده - مهدي سيف اللهي
لیست اسناد و منابع اینترنتی | امیر حسین مرتضوی
آموزش متدولوژی و تکنولوژی طراحی وب CIW | بیتا ضرابیان
مفاهیم Java و Active-x | ریحانه عارفی مقدم
آشنایی با مفاهیم و اصطلاحات اینترنتی | بیتا ضرابیان
مفاهیم پایه فن آوری اطلاعات - مهارت اول از ICDL | ریحانه عارفی مقدم
آموزش سیستم عامل ویندوز 98 - مهارت دوم از ICDL | مهرداد گلشنی
آموزش Word - مهارت سوم از ICDL | ویدا زارعی
آموزش Power Point -مهارت ششم از ICDL | مهشید ملالی
مقدمه ای بر ویروسها و برنامه های مخرب | آرش رضا پور خان
آشنایی با Access - مهارت پنجم از ICDL | فائزه شهيدي
آموزش Flash-MX ( مقدماتي) | مازيار مصبريان
كد نويسي با جاوا اسكريپت | بيتا ضرابيان
آموزش Excel2000 - مهارت چهارم از ICDL | مدیا صداقت کیش
آموزش مهارت رفتاري | ابراهيم خليل اخوان

دوره هاي آموزشي

آموزش فتوشاپ
آموزش HTML
 آموزش اینترنت - مهارت هفتم از ICDL
آموزش مباحث پيشرفته در طراحي صفحات وبjavascript - SQL - ADO
لیست اسناد و منابع اینترنتی
آموزش متدولوژی و تکنولوژی طراحی وب CIW
 مفاهیم Java و Active-x
 آشنایی با مفاهیم و اصطلاحات اینترنتی
 مفاهیم پایه فن آوری اطلاعات - مهارت اول از ICDL
آموزش سیستم عامل ویندوز 98 - مهارت دوم از ICDL
آموزش Word - مهارت سوم از ICDL
 آموزش Power Point -مهارت ششم از ICDL
مقدمه ای بر ویروسها و برنامه های مخرب
 آشنایی با Access - مهارت پنجم از ICDL
آموزش Flash-MX ( مقدماتي)
 كد نويسي با جاوا اسكريپت
آموزش Excel2000 - مهارت چهارم از ICDL
آموزش مهارت رفتاري

بازديد كنندگان


New Page 1

آموزش HTML > ضمیمه

معرفی منبع - تماس با نویسنده


New Page 1

آموزش HTML > فصل اول

مقدمه
درس 1 - ایجاد اولین سند HTML
درس 2 - ویرایش یک سند HTML
درس 3 - نشانه گذاری 6 درجه
درس 4 - شکستن پاراگراف


New Page 1

آموزش HTML > فصل دوم

درس 5 - سبکهای مختلف نوشتاری
درس 6 - < ul >, < ol > لیستها
درس 7 - قالب بندی فایلهای گرافیکی و استاندارد های مورد استفاده در صفحات وب
درس -٧-ب - قرار دادن تصاوير در اسناد


New Page 1

آموزش HTML > فصل سوم

درس 8 - LINK ( اتصال )
٨-ب - لينك به سايت ديگر
٨-ج اتصال به یک سایت دیگر از اینترنت
٨-د - اتصال به قسمتی از همان صفحه
٨-ه - اتصالات ابر متن و تصویرهای لینک شده
درس 9 - به رديف در آوردن متن


New Page 1

آموزش HTML > فصل چهارم

درس 10 - کاراکترهای ویژه
درس 11 - لیستهای تعریف
درس 12 - آدرسهای زیر نویس و اتصالات email
درس 13 - وارد کردن یک توده متن بطوریکه از بقیه متن متمایز باشد .
درس 14 - گذاشتن بافت براي صفحه
درس 15 - عدم استفاده از تگهای blink و Marquee


New Page 1

آموزش HTML > فصل پنجم

درس 16 - زیبا کردن متن
درس 17 - ايجاد خط
درس 18 - Extra Alignment
درس 19 - آرایش در جدول
درس 20 - نقشه های تصویری


New Page 1

آموزش HTML > فصل ششم

درس 21 - Meta tag
درس 22 - پنجره Target
درس 23 - فریم کردن صفحه
درس 24 - اضافه کردن فرم به صفحات وب
درس ٢٤-ب - بوجود آوردن فرم ها
درس 25 - چند رسانه ای در صفحات شما
25 -ب - اضافه کردن فیلم و صوت -multimedia
درس 25 - ج - قالبهاي صوتي مورد استفاده


New Page 1

آموزش HTML >فصل اول > مقدمه

مقدمه

بنام یگانه ی هستی

HTML مخفف Hyper text mark up language ( زبان کد گذاری ابر متن ) می باشد .
HTML در واقع زبان ساخت صفحات وب می باشد . این صفحات می تواند حاوی متنهای آرایش شده ، Link ، تصاویر ، جدول ، Plug – in و ... باشند . استقبال زیاد از این زبان و همچنین کمبود کتابهایی که در این زمینه وجود دارند ما را بر آن داشت تا بدون پرداختن به جزئیات بسیار ریز و غیر ضروری ، منبعی ساده و در عین حال کلی ارائه دهیم که مطالعه آن برای خوانندگان خالی از لطف نخواهد بود .
جهت کد نویسی و طراحی صفحات وب نیاز به یک Text Editor ساده مانند Notepad که در تمامی ویندوزها قابل دسترسی می باشد و نیاز به نصب Text Editor جدید نیست .
برای مطالعه ی این دوره ی آموزشی نیاز است کاربران محترم آشنایی با اینترنت داشته باشند .

ضمنا سیستم شما باید دارای مشخصات سخت افزاری ذیل باشد :

- حداقل سیستم مورد نیاز پنتیوم 233
- 16 مگابایت Ram
- حدود 600 مگا بایت فضای آزاد

در پایان از کاربران محترم خواهشمند است در صورت داشتن هر گونه انتقاد ، پیشنهاد و ارائه سوالات احتمالی با نویسنده از طریق پست الکترونیکی bzarabian@etvto.ir تماس حاصل نمایند .

پیروز و سربلند باشید
بیتا ضرابیان


New Page 1

آموزش HTML >فصل سوم > ٨-ب - لينك به سايت ديگر

٨-ب - لينك به سايت ديگر

اهداف این درس

1- شناسایی وظیفه یک URL
2- تشخیص ساختار یک URL
3- امتحان یک اتصال به یک URL

تذکر:

برای این درس شما نیاز به فایل متنی HTML ندارید.
URL چیست ؟

Uniform Resource Location -URL آدرسی است که www از آن برای پیدا کردن فایلها و اسناد کامپیوترها در روی اینترنت از آن استفاده می کند در مرورگر شما URL این سند در قسمت آدرس با مرورگر شما تایپ شده است . یک مرورگر URL شامل قسمتهای زیر است :
1- معین کننده هویت
2- معین کننده هویت و آدرس
3- مسیر کامل فایل منحصر به فرد
URL چیزی است که شما برای ساختن یک اتصال از یک صفحه وبی که خودتان ایجاد کرده اید برای اتصال به اطلاعات دیگر قابل دسترسی بر روی اینترنت به آن احتیاج پیدا خواهید کرد .

ساختار URL چگونه بنا می شود ؟

- چگونگی ایجاد یک URL
ساختار یک سند URL بصورت زیر است : Type:\\inter.net.address/directory/…/filename کلمه Type (نوع ) اشاره بر نوع Internet server دارد که شروع کننده یک URL است .
http برای web server است که مخفف است که مخفف hyper text transfer prorocol می باشد .سایت اینترنتی گوفر اطلاعات شاخه ها و منوهای منتقل شده می باشد.

FTP

مخفف کلمات File Transfer protocol که به FTP ناشناس شهرت دارد و آرشیوی از فایلهاست .

Telnet

ایجاد یک جلسه Telnet برای دسترسی به کامپیوتر را دور وقتی مرورگر وب خود را انتخاب می کنید برای Telnet آماده خواهد شد و یک برنامه خارجی را به یک سایت مشخص اتصال پیدا می کند.

WAIS

مخفف کلمات Area Indexed server سروری برای جستجو موضوعات و اسناد جهت دار با استفاده از لغات کلیدی .

File

فایلها بر روی کامپیوتر شما (فلاپی ، هارد دیسک ، ... ) این نوع آدرس دهی همیشه با :// دنبال می شود و آدرس اینترنت یک کامپیوتر راه دور مانند آدرس فوق
Host.Domain.Domain.Domain

برای مثال:

Machine department.college.edu
123.45.6.78
office.company.com
agency.branch.gov
machine . organization.country
توجه داشته باشید که یک URL می تواند شما را به هر سایت ، شاخه ، زیر شاخه ، فایل متنی ، تصویر و فیلم یا صدا و یا هر سایتی که آرایش شده برای ترسیم عمومی متصل کند. بهترین روش برای پیدا کردن URL های مختلف حرکت دادن ماوس و لینک کردن آن بر روی ابر متن های در صفحه می باشد . اگر به قسمت بالای مرورگر خود دقت کنید URL می توانید در آن قسمت به نمایش در آید . همچنین شما به وسیله URL می توانید به سایتهای بزرگ نظیر Yahoo و ... دسترسی پیدا کنید.

مروری بر مطالب

1- هدف ایجاد URL برای www چیست ؟
2- در کجای صفحه وب می توان URL ها را پیدا کرد ؟
3- ساختار اصلی یک URL چیست ؟
4- وقتی به وسیله یک ابرمتن اتصال به جایی پیدا می کنید URL را چگونه می بینید ؟

تمرین

بر روی ابر متن های یک سایت کلیک کنید و عوض شدن URL ها در قسمت بالای صفحه را بررسی کنید .


New Page 1

آموزش HTML >فصل سوم > ٨-ج اتصال به یک سایت دیگر از اینترنت

٨-ج اتصال به یک سایت دیگر از اینترنت

اهداف این درس

1- ایجاد یک اتصال به یک سایت دیگر اینترنت
2- ایجاد یک URL در سند HTML برای استفاده و اتصال از طریق سایت شما

شروع درس

HTML برای اتصال به اینترنت
اتصال به یک سایت اینترنتی ترکیبی است از دو مبحث اتصال به یک فایل محلی درس (8a ) و هر آنچه که در درس (8a ) در مورد URL آموختیم قالب HTML کلی این اتصال بصورت زیر است :

URL آدرس سایتی است که شما می خواهید از آن دیدن کنید .link
یک رشته لینک فعال که بصورت ابرمتن در مرورگر وب نشان داده می شود ، معمولا اما نه همیشه با خط آبی که در زیر آن کشیده شده مشخص می شود. وقتی یک بیننده بر روی ابر متن کلیک می کند مرورگر وب به یک سایت دیگر بوسیله یک URL اتصال پیدا می کند . توجه داشته باشید که URL می تواند شما را به www و FTP و Gopher ، متن و عکس و ... متصل کند . می خواهیم یک ابرمتن در سایت ایجاد کنیم برای دسترسی به سایتهایی که در مورد آموزش از راه دور می باشد .
1- فایل Index.html را باز کنید.
2- متن زیر را اضافه کنید :

برای دیدن سایتهای آموزش از راه دور
3- ذخیره سند خود

تذکر :

برای اینکه در سایت خود اتصالی داشته باشید که شما را به یک عکس در یک سایت اینترنتی دیگر متصل کند باید آدرس کامل آن عکس را در URL خود ذکر کنید.

روش آسان برای وارد کردن یک URL در یک تگ

از آنجایی که ماهیت یک صفحه وب و آدرس آن در قسمت آدرس بار ظاهر می شود و شما می توانید روی آدرس بار بر روی آدرس کلیک کرده و آن را انتخاب کنید و گزینه Copy را انتخاب کنید سپس مراحل زیر را انجام دهید .
1- فایل index.html را باز کنید .
2- متن زیر را وارد کنید .

3- به آدرس www.webtraning.com متصل شوید.
4- در این صفحه وب از آدرس بار URL را انتخاب کنید .
5- از منوی Edit گزینه Copy را انتخاب کنید .
6- حال به سند index.html خود باز گردید.
7- ماوس را مابین index.html در جایی که می خواهیم URL را وارد کنیم قرار می دهیم و سپس Paste کنید .

مروری بر مطالب

1- آدرسهای اینترنتی چه هستند ؟
2- مراحلی که باید برای گذاشتن یک Link -URL در صفحه وب دنبال کنید چیست ؟
3- راه آسان وارد کردن URL چیست ؟
4- گزارشی از انواع لینکهایی که در صفحه قرار دادید داشته باشید .

تمرین

در صفحه وب خود را از اتصالاتی که شما را به URL متصل می کند استفاده کنید .


New Page 1

آموزش HTML >فصل سوم > ٨-د - اتصال به قسمتی از همان صفحه

٨-د - اتصال به قسمتی از همان صفحه

تگ < name >

اهداف این درس

1 - ایجاد یک شاخه مخفی برای اشاره به یک قسمت خاص از یک سند HTML
2- ساخت و ایجاد یک اتصال ابرمتن که به بخش خاصی از یک سند متصل شوید .
3- ساخت یک ابرمتن برای اتصال به قسمتی از یک صفحه در یک سند HTML دیگر
4- ایجاد انواعی از ابر متنها برای صفحه وب

شروع درس

Anchor name یک نشانه مخفی ، برای اشاره به یک بخش خاصی از یک سند HTML و نیز می تواند برای اتصال به قسمتی از یک صفحه دیگر کاربرد داشته باشد . برای مثال می توانیم در یک صفحه ( در اینجا ) یک اتصال درست کنیم که با کلیلک بر روی آن به قسمت آخر صفحه پرش پیدا کنید .
قالب HTML آن عبارتست از
< a name="name" >Text to link to < /a >

نوشتن و ایجاد یک لینک (Name Anchor)

هنگامی که می خواهید یک ( Name Anchor ) ایجاد کنید مراحل زیر را دنبال کنید .

کاراکتر "#" به مرورگر شما می فهماند که باید در داخل سند به دنبال Anchor name باشد . اضافه کردن یک name anchor به index.html که در قبل ساختید.
1- سند index.html را باز کنید .
2- در بالای این متن را اضافه کنید .

3- در یک روش یکسان مانند بالا موارد زیر را نیز انتخاب کنید .

4- اگر صفحه را مجددا بارگذاری کنید از تغییراتی که انجام دادید چیزی دیده نمی شود و از چشم کاربر مخفی است .
اضافه کردن اتصالات (Name Anchor) به همان سند
1- باز کردن فایل Index.html
2- موارد زیر را اضافه کنید .
3- سند خود را ذخیره کنید و آن را مجددا بارگذاری کنید .
در پایان ما می خواهیم که هر کدام از موارد لیست بالا بصورت ابرمتنی باشند که ما را به قسمتی از همین صفحه هدایت کنند .
1- صفحه index.html را در ویرایشگر متنی باز کنید .
2- اولین مورد را بصورت فوق تغییر دهید .

3- نتایج خود را ذخیره و صفحه را مجددا بارگذاری نمایید.

اضافه کردن یک اتصال Anchor name به یک سند دیگر

شما میتوانید یک اتصال ایجاد کنید که به وسیله آن به قسمتی از یک سند دیگر هدایت شوید که دستور آن بصورت زیر است :

اگر چنین سندی در صفحه دیگری وجود داشته باشد
برای ایجاد چنین لینکی مراحل زیر را دنبال کنید :
1- سند Lesson1.html را که در قبل ایجاد کردید باز کنید .
2- در بین تگ و متن زیر را وارد کنید :

3- اسناد خود را ذخیره کرده و صفحه را مجددا بارگذاری کنید .
وقتی که بر روی ابر متن Return to training the web کلیک می کنیم و در صفحه Index.html در قسمت آموزش آن می شوید .

آزمایش

مروری بر مطالب

1- چگونه یک تگ Anchor name را می شناسید؟
2- مراحل ایجاد یک لینک به قسمت دیگر از یک صفحه چیست؟
3- چگونه این لینک را برای اتصال به قسمت صفحه دیگر آرایش می کنید؟
4- تفاوت بین تگ های زیر چیست ؟

تمرین

در صفحه خود از انواع name anchor استفاده کنید


New Page 1

آموزش HTML >فصل سوم > ٨-ه - اتصالات ابر متن و تصویرهای لینک شده

٨-ه - اتصالات ابر متن و تصویرهای لینک شده

اهداف این درس

1- وارد کردن یک دگمه گرافیکی در صفحه وب برای اتصال به سند دیگر HTML
2- وارد کردن یک تصویر کوچک که مانند یک تمبر پستی برای نمایش یک Copy از عکس بزرگتر عمل می کند.

شروع درس

دکمه های اتصال

از درس قبل آموختید که چگونه یک ابر متن در سند خود ایجاد کنید که بیننده را به اطلاعات وابسته اتصال دهد. همچنین در درس (a 7) آموختید که چگونه یک عکس خطی را بصورت لینک در آورید . اگر بیاد بیاورید در درسهای قبل که یک رشته متن در Index.html -Lesson1.html را به صفحه دوم Lesson2.html اتصال دادیم که توضیح داده شد( در مورد آموزش از راه دور) حال در این صفحه می خواهیم بدانیم که چگونه یک دکمه اضافه کنیم که با اتصال بر روی آن ما را به صفحه اول بر گرداند.
به دستور زیر توجه کنید :
< a href="filex.html" >< img src="qraphic.gif" >go to document< /a >
دو صفحه وب شما رشته متن Go to Document و تصویر هر دو بصورت ابراتصال عمل می کنند و با کلیک بر روی آن به مرورگر می فهمانید که باید به صفحه filex.html باز گردد . معمولا متنها و عکسهایی که با حالت ابر اتصال باشند در صفحه متمایز هستند. امروزه خیلی از مرورگرها می توانند رنگ ابر متن را تغییر دهند . معمولا شما می توانید شناسایی کنید یک نامه ابرمتن در صفحه وب را به وسیله کشیدن ماوس روی آن تغییر رنگ می دهد و نیز هنگامی که یکبار بر روی متن کلیک کنید در بازگشت رنگ ابرمتن های بازدید شده تغییر کرده است از نقطه نظر یک طراح وب پیشنهاد می کنیم که وقتی می خواهید از تصویر به عنوان یک اتصال استفاده کنید . همچنین در تگ < Img> از صفات دیگری مثل attribute و Alt نیز استفاده می شود . کاربر با بارگذاری عکس را متوقف می کند حال می خواهیم یک اتصال گرافیکی ایجاد کنیم . در ابتدا باید در جایی از کامپیوتر خود عکس را ذخیره کنید .
1- صفحه Lesson1.html را باز کنید.
2- در بالای صفحه تغییرات زیر را ایجاد کنید :

3- نتایج خود را ذخیره و صفحه را مجددا بار گذاری کنید .
حال دوباره به سند Lesson1.html باز گردید.
1- صفحه Lesson1.html را باز کنید .
2- تغییرات زیر را در صفحه انجام دهید :

تذکر :

در تگ < Img src > از صفات height و width برای کوچک کردن تصویر استفاده کنید بطوریکه با کلیک روی آن عکس بزرگ به نمایش در آید .
مروری بر مطالب

1- چگونه یک دکمه گرافیکی در صفحه ایجاد می کنید ؟

تمرین

مطالب گفته شده را در صفحه خود بکار ببرید .


New Page 1

آموزش HTML >فصل سوم > درس 9 - به رديف در آوردن متن

درس 9 - به رديف در آوردن متن

اهداف این درس

- به ردیف در آوردن متن
- کنترل بر جاهای دقیق متن و کاراکترها

شروع درس

در درس قبل آموختیم که مرورگر کلیه فضاهای خالی که در صفحه قرار دادیم چشم پوشی می کند ، به هر جهت بعضی از مواردنحوه آرایش کلمات در حمایت از طرح و ترکیب کلی صفحه مهم است . تگ Performat صفحه شما را دقیقا مانند آنچه که در ویرایشگر متنی تایپ نمودید نشان می دهد.
M n o s p a c e d
در ادامه بحث مطالب زیر را دنبال می کنیم :
1- فایل HTML با نام Index.html را در ویرایشگر خود باز کنید و موارد زیر را اضافه کنید .

نام دورهاي اموزشي
نام دوره اموزشي | نام مدرس
internet | ---
html | ---
- نتایج خود را ذخیره کنید و صفحه را مجددا بارگذاری کنید .

مروری بر مطالب

1- در هنگام ترجمه مرورگر تگ Preformat چگونه عمل می کند؟
2- در چه مواقعی از این تگ استفاده می شود؟


New Page 1

آموزش HTML >فصل چهارم > درس 10 - کاراکترهای ویژه

درس 10 - کاراکترهای ویژه

اهداف این درس

- نشانه گذاری در HTML
- استفاده از علامات < > در هنگام لزوم در سند
- گذاشتن فاصله اضافی در بین کاراکترها

نشانه های تایید

بعضی اوقات در صفحه نیاز دارید از بعضی کاراکترهای ویژه استفاده کنید که به Iso مشهور هستند و در HTML نشان xxxxxxx مشخص می شوند.
برای دیدن مرجع این نشانه ها به آدرس زیر مراجعه کنید:
Iso characters
http://www.htmlhelp.com/refrence/charset
ممکن است بعضی اوقات مجبور به استفاده از علامت کوچکتر و بزرگتر < > در صفحه باشد که برای اینکه مرورگر آنها را بصورت Code ترجمه نکند .برای نمایش آنها نیاز به استفاده از کاراکترهای ویژه دارید.
< استفاده می شود برای &Lt
> استفاده می شود برای >
& استفاده می شود برای & amp

ایجاد فضای خالی

می دانید که مرورگر از بیشتر فضای خالی که ایجاد می کنید چشم پوشی می کند به هر جهت شاید در طراحی یک صفحه به جایی برسید که بخواهید از بیشتر از یک فضای خالی استفاده کنید. در اینصورت از کاراکتر nbps& استفاده کنید .

جدول کاراکترهای ویژه

Name | HTML
Copyright | & copy;
Trademark | & reg;
Cent | & cent;
Deqree sign | -& deg ;
double-less than | & laquo ;
Midline dot | & middot;
Micron | & micro ;

مروری بر مطالب

1- برای گذاشتن علامت بزرگتر و کوچکتر چه روشی دارید؟
2- برای گذاشتن فاصله چه می کنید ؟

تمرین

در صفحه وب خود از کاراکترهای ویژه استفاده کنید .


New Page 1

آموزش HTML >فصل چهارم > درس 11 - لیستهای تعریف

درس 11 - لیستهای تعریف

اهداف این درس

1- ایجاد لیستهای تعریف با متنهای جداگانه
برای تعریف اقلام
2- ایجاد تاریخچه با لیست تعریف
در درس 6 آموختیم که چگونه لیست تعریف ایجاد کنیم . حال می خواهیم نوع سومی از لیست که به لیستهای تعریف معروف است ایجاد کنیم . در قبل در جلوی اقلام لیست از نقطه استفاده نمی کردیم ولی در اینجا جلوی هر قلم از لیست یک نقطه داریم .
قالب HTML این نوع لیست بصورت زیر است :

تگ < dl> و < dl /> بصورت زوج عمل می کند و < dd > و < dt > بصورت فرد
در فایل index.html موارد آموزشی را بصورت لیست تعریف دربیاورید . کار خود را آزمایش کنید .

مروری بر مطالب

1- چه فرقی بین لیست تعریف و لیستهای مرتب و نامرتب وجود دارد؟
2- در چه مواردی باید لیست تعریف بکار برد؟
3- چه فرقی بین دو تگ < dt > و < dd > وجود دارد ؟

تذکر :

شما می توانید لیستهای مرتب و نامرتب را با لیستهای تعریف با هم به کار ببرید .
oxielex
Combinations of metal ions with oxygen Comprises the major ores extracted in mining operations
  • Hematite
  • maquetite
  • corundum

Source آن بصورت زیر است :


New Page 1

آموزش HTML >فصل چهارم > درس 12 - آدرسهای زیر نویس و اتصالات email

درس 12 - آدرسهای زیر نویس و اتصالات email

توانائیها

1- گذاشتن سر فصل و پاورقی برای صفحات
2- ایجاد ابر متن هایی برای ارسال
email
شروع درس

وجود سر تیتر و پاورقی برای صفحات وب ارزش زیادی دارد و قطعا تاریخ آخرین ویرایش می تواند اهمیت زیادی داشته باشد.
عقیده خوبی برای گذاشتن سر فصل و پاورقی مثبت بین 2 صفحه وب برخی از اطلاعات مفید در این زمینه عبارتست از :
1- سر فصل و موضوع صفحه جاری
2- تاریخ ایجاد سند
3- محفوظ بودن حق کپی
4- اسم و آدرس پست الکترونیکی
5- نام و ابر متن برای اتصال به سازمان یا ارگان
قالب آن بصورت زیر است :
< address > text text text < /address >
فرض کنید شخصی در حال خواندن صفحه شما می باشد و مایل است نکاتی را به شما توصیه کند . شما باید آدرس پست الکترونیکی خود را در صفحه بیاورید و شما می توانید به وسیله یک اتصال از طریق مرورگر این کار را انجام دهید . اکثر مرورگرها ی امروزی این کار را انجام می دهند .
روش انجام این کار گذاشتن ابر متنی با دستور mailto می باشد :

هنگامی که متن Send email کلیک شود مرورگر وب شما صفحه Compose را فراهم آورد و شما می توانید پیامی را در آن تایپ کنید و ممکن است در همه مرورگرها جواب نگیریم . می توانید در صفحه خود از چنین اتصالاتی استفاده کنید.

اگر شما بخواهید یک پیام را به چند نفر ارسال کنید شما می توانید در تگ Mailto آدرسهای زیادی قرار دهید و آنها را با کاما از هم جدا کنید .

send email
برای اضافه کردن پاورقی یا مواردی مثل آدرس سازمان یا شرکت و ... می توانید متن یا آدرس مورد نظر را بین دو تگ < address > و < /address > بیاورید . مثلا :


New Page 1

آموزش HTML >فصل چهارم > درس 13 - وارد کردن یک توده متن بطوریکه از بقیه متن متمایز باشد .

درس 13 - وارد کردن یک توده متن بطوریکه از بقیه متن متمایز باشد .

وارد کردن تگ blackquotes در صفحه

شروع درس

در زبان نوشتاری کوتیشن می تواند جمله ای را از بقیه متن نوشته شده متمایز سازد HTML نیز این توانایی را دارد

شما می توانید اقلام دیگری مثل لیستها و ... را بوجود آورید .
1- سند index.html را باز کنید .
2- یک توده متن به آن اضافه کنید و آن را داخل کوتیشن قرار دهید .
3- نتایج را ذخیره و صفحه را مجددا بارگذاری کنید .

مروری بر مطالب

1- تگ < blockquote > چه عملی انجام می دهد ؟
2- چرا نیاز به استفاده از تگ < p > قبل از تگ < blockquote > ندارید ؟


New Page 1

آموزش HTML >فصل چهارم > درس 14 - گذاشتن بافت براي صفحه

درس 14 - گذاشتن بافت براي صفحه

اهداف این درس

1- گذاشتن یک رنگ به عنوان پیش زمینه
2- محاسبه اعداد از مبنای 10 به مبنای 16
3- عوض کردن رنگ فونت و لینکها
4- ایجاد یک پیش زمینه از عکس در صفحه وب

شروع درس

با ایجاد بعضی تغییرات در تگ < body > می توانید رنگی را به عنوان پیش زمینه صفحه خود انتخاب کنید .
Hexadecimal
در مرورگرتان رنگهای زیادی برای استفاده در دسترس دارید . هر رنگی با 3 رنگ سبز و قرمز و آبی معرفی شده است .
(r=255,g=255,b=255) تولید کننده رنگ سفید و مینیمم آنها (r=0,g=0,b=0) تولید کننده رنگ مشکی خواهد بود .
شما به اعداد 102 ، 153 ، 205 نگاه کنید . هر کدام از این اعداد در مبنای 10 هستند که باید به مبنای 16 تبدیل شوند .
اعداد با مبنای 16 برای کامپیوتر قابل فهم هستند . اگر بخواهیم عدد بالا را در مبنای 16 ببریم خواهیم داشت : ff6699
که 66 ارزش رنگ قرمز 99 ارزش رنگ سبز و ff ارزش رنگ آبی را معلوم می کند .

انتخاب رنگ یکپارچه برای background

برای استفاده از رنگ یکپارچه برای background از تگ زیر استفاده می شود :

شما می توانید تغییرات زیر را در تگ ایجاد کنید

پیش زمینه با بافت ویژه

استفاده از رنگ یکپارچه به صفحه شفافیت و تنوع می بخشد . اما می توانید با قرار دادن یک تصویر به عنوان پیش زمینه قدری جلوتر حرکت کنید . شما می توانید از تصاویر کوچک gif.jpeg به عنوان پیش زمینه در صفحات خود استفاده کنید .
نکاتی که باید در نظر بگیرید عبارتند از :
1- برای گذاشتن عکس به عنوان پیش زمینه باید از عکسهای با سایز مناسب کمتر از 10 kb استفاده شود .
2- سعی کنید از عکسهایی که روشن هستند استفاده کنید .
3- صفحاتی که در پیش زمینه آنها از عکس استفاده شده است در هنگام بارگذاری صفحه باید ابتدا عکس آنها بارگذاری شود بنابراین برای ارتباط با سرعت پایین مشکل بوجود می آید .

مروری بر مطالب

1- چگونه از یک رنگ یکپارچه در صفحه خود استفاده می کنید ؟
2- چرا اعداد بصورت ff66cc نوشته می شود ؟
3- چه فرقی بین دو تگ [image] وجود دارد ؟


New Page 1

آموزش HTML >فصل اول > درس 1 - ایجاد اولین سند HTML

درس 1 - ایجاد اولین سند HTML

بعد از خواندن این درس توانائیهای زیر را در ساخت صفحات وب بدست می آورید:
1- آشنایی و درک تگهای HTML
2- باز کردن محیط کاری متناسب برای ایجاد یک سند HTML
3- استفاده از یک Editor (ویرایشگر متنی )
4- وارد کردن مطالبی به عنوان توصیه بطوریکه در صفحه نشان داده نشود
5- باز کردن سند در Browser برای نمایش آن تحت وب

1- تگ های HTML

وقتی یک مرورگر وب صفحه ای مانند صفحه فوق که شما مطالعه می کنید را نشان می دهد، صفحه از یک فایل متنی خوانده میشود.
کدهای ویژه اي بکار برده شده اند که با علامات <> نشانه گذاری شده اند. قالب عمومی تگ های HTML بصورت فوق می باشد :
< نام تگ / >رشته کاراکتری < نام تگ >
(البته بعضی تگها بصورت فرد عمل می کنند )
مانند:

این تگ بیان می کند که مرورگر وب متنی را بصورت زیر نمایش می دهد :
What are HTML tags
- بعدا در مورد تگهای < Hn > توضیح بیشتری خواهیم داد.

تذکر :

مرورگر وب نسبت به استفاده از حروف بزرگ یا کوچک حساسیت ندارد.بر خلاف برنامه های کامپیوتر ، اگر شما ایرادی در HTML داشته باشید ، کامپیوتر شما دچار هنگ نمی شود و ایراد بسادگی با رفتن در داخل سند HTML بر طرف میشود. مرورگر شما ، دارای یک سند لغات کوچک می باشد . یکی از جنبه های جذاب HTML ، این است که اگر Browser شما نداند که تگی که در آن نوشته شده چیست ، آن را نادیده می گیرد. برای مثال :

مثلا تگ < H3 > < /H3 > مورد حمایت مرورگر قرار می گیرند . ولی با مرورگرهای فعلی < wiggle /> و < wiggle > حمایت نمی شوند . اگر ما برنامه نویس یک مرورگر وب بودیم عملکردی برای تگ < wiggle > در نظر می گرفتیم .

2- باز کردن محیط کاری

برای کامل کردن این بحث ، از ابتدا بهتر است که یک پنجره جدید ایجاد کنید. برای اینکه به شما اجازه می دهد که ضمن نگهداری پنجره فعلی ، پنجره ای جدید برای کار خودداشته باشید. شما خیلی راحت می توانید بین پنجره ها و اطلاعات مختلف گردش داشته باشید . مراحل ایجاد محیط کاری را در اینجا بیان می کنیم :
1- از منوی File مرورگر خود ، گزینه New Window را انتخاب کنید . پنجره دوم ظاهر می شود . اولین پنجره کتاب شماست و پنجره دوم محیط کاری برای تکمیل دروس HTML
2- فایل متنی خود را باز کنید
3- ایجاد سند HTMl
یک سند HTML شامل دو قسمت می باشد ( قسمت های تیتر و بدنه )
- قسمت تیتر ، شامل اطلاعاتی در مورد سندی که نشان داده می شود است .
- بدنه ، شامل کلیه مواردی می باشد که در یک صفحه وب نشان داده می شود .

نمونه یک سند HTML

استفاده از مطالبی که توضیح راجع به سند باشد و در صفحه نشان داده نمی شود

هر آنچه در صفحه نشان داده می شود
این تگ توضیحاتی دارد مبنی بر اینکه برای نوشتن این صفحه از کدام ورژن HTML استفاده شده است . تمامی مندرجات صفحه بین 2 دو تگ < HTML> و < html /> نوشته می شود . ابتدا < Head > و < head / > و سپس < body > و < body / > < ! …… > متنی که ما بین تگ فوق نوشته می شود ، در صفحه وب نمایش داده نمی شود، ولی این اطلاعات در اختیار کسی قرار می گیرد که Source یک صفحه وب را که در پشت صفحه وب قرار دارد می بیند .
وقتی صفحه وب شما دچار پیچیدگی می شود، این مطالب و کدها می تواند برای به روز کردن صفحه وب شما مفید باشد . اینجا به ذکر مراحل ایجاد سند HTML می پردازیم :
1- Editor متنی خود را باز کنید
2- و مطالب زیر را در آن وارد کنید :

موقعیت تگ < title > و < title /> داخل دو تگ < head > و < head /> می باشد و این که در صفحه نشان داده نمی شود پس کار آن چیست ؟
تگ < html > شناسه یگانه ای است برای هر سند HTML و در قسمت Title bar بار مرورگر شما نمایش داده می شود .
در درس 3 شما می آموزید که چگونه رشته کاراکتر را برای Title اضافه کنید و در صفحه وب شما ظاهر شود . ذکر این نکته ضروری است که دراین تگ توضیح اسم نویسنده و تاریخ ایجاد سند HTML ذکر می شود و شما می توانید هر نکته ای را درون این تگها نمایش دهید . ولی فقط در سند HTML قابل رویت می باشد و در صفحه وب شما قابل مشاهده نیست.
3- سند خود را به نام Lesson1.html ذخیره کنید و آن را در فولدر خاص مورد نظر خود نگهداری کنید .

تذکر ( برای استفاده کنندگان ویندوز 3.1 ) :

شما باید سند HTML خود را با نام HTM .نام فایل ذخیره کنید . بنابراین نام فایل شما در این مثال Lesson1.htm خواهد بود . نگران نباشید مرورگر شما به اندازه کافی هوشمند می باشد و می داند که آخر نام فایل شما HTM می باشد . HTM نیز یک فایل HTML می باشد .
استفاده کنندگان ویندوز 95 به بالا می توانند نام فایل را Lesson1.html قرار دهند . طبق مثال فوق با استفاده از این اسم و پسوند مرورگر فایل شما را مانند یک فایل HTML می خواند و آن را بصورت صفحه وب نشان می دهد .

نمایش سند در یک صفحه وب

1- بر گردید به مرورگر وب که برای محیط کاری از آن استفاده می کنید . از منوی File گزینه Open را انتخاب کنید .
2- از کادر محاوره ای که باز می شود ، سند مورد نظر ایجاد شده را باز کنید .
3- حال در Title bar مرورگر خواهید دید Lesson 1

چک کردن فایل

سند خود را با صفحه وبی که در پیش رو داریدمقایسه کنید، بعد از نگاه کردن نمونه از دکمه Toolbar back استفاده کنید تا مرورگر شما دوباره به این صفحه باز گردد . اگر سند شما با سند نمونه تفاوت داشت دوباره مروری بر مطالبی که وارد کردید داشته باشید . از اشتباهات معمولی که وجود دارد عدم مشاهده Titlebar می باشد . متنی که بین تگ های < title > و < title /> قرار داده شده در Title بار نشان داده نمی شود . از اشتباهات معمول دیگر برای کسانی است که از برنامه های پردازشگر لغات برای Type HTML استفاده می کنند و نمیتوانند آن را در مرورگر باز کنند .در این صورت صفحه آنها پر از کاراکترهای اضافی است .
اگر شما به دنبال یک Editor ساده و ارزان هستید پیشنهاد ما به شما Notepad می باشد

مرور عناوین

1- تگ های HTML چه هستند ؟
2- متن تگ Title در کجا قرار می گیرد؟
3- چه مراحلی را برای ایجاد یک سند HTML باید دنبال کرد ؟
4- چگونه یک تگ توضیح ایجاد می شود ؟
5- چگونه می توانید سند HTML خود را در مرورگر نمایش دهید ؟

یک تمرین :

یک سند HTML که شامل تگ Title باشد ایجاد کنید و سپس آن را در مرورگر نمایش دهید . "حال صفحه اول شما ساخته شد"


New Page 1

آموزش HTML >فصل چهارم > درس 15 - عدم استفاده از تگهای blink و Marquee

درس 15 - عدم استفاده از تگهای blink و Marquee

عدم استفاده از تگهای < blink > و < Marquee >

اهداف این درس

1- عدم استفاده از تگ < blink >
2- عدم استفاده از تگ < Marquee >
3- دلیل استفاده از HTML استاندارد

شروع درس

وقتی که یک صفحه وب با مرورگر NetScape باز می شود این مرورگر تگی را نمایان می سازد که به لغت یا قسمتی از جمله تاکید خاصی دارد .
این تگ عبارتست از : < blink >wow< /blink >
از آوردن این تگ در صفحات خود اجتناب کنید . زیرا در بیشتر مرورگرهای وب کارآیی ندارد . اگر شما متن زیر را در مرورگر NetScape مشاهده کنید . آن را چشمک زن می بینید .
عکس زیر در یک فایل Gif می باشد . عملی را که باید این متن در مرورگر Netscape انجام شود را به شما نشان می دهد. در اینجا یک فایل Gif آورده شده است. .
اما ! ! ! شرکت مایکروسافت تگی برای ایجاد حرکت در Internet explorer ایجاد کرده است که عبارتست از < marquee >wow < /marquee >
اما اگر آن را مرورگر Netscape نبینید هیچ حرکتی ندارید . پس بهتر است از این 2 تگ در صفحات وب خود استفاده نکنید .

دوره هاي آموزشي

آموزش فتوشاپ
آموزش HTML
 آموزش اینترنت - مهارت هفتم از ICDL
آموزش مباحث پيشرفته در طراحي صفحات وبjavascript - SQL - ADO
لیست اسناد و منابع اینترنتی
آموزش متدولوژی و تکنولوژی طراحی وب CIW
 مفاهیم Java و Active-x
 آشنایی با مفاهیم و اصطلاحات اینترنتی
 مفاهیم پایه فن آوری اطلاعات - مهارت اول از ICDL
آموزش سیستم عامل ویندوز 98 - مهارت دوم از ICDL
آموزش Word - مهارت سوم از ICDL
 آموزش Power Point -مهارت ششم از ICDL
مقدمه ای بر ویروسها و برنامه های مخرب
 آشنایی با Access - مهارت پنجم از ICDL
آموزش Flash-MX ( مقدماتي)
 كد نويسي با جاوا اسكريپت
آموزش Excel2000 - مهارت چهارم از ICDL
آموزش مهارت رفتاري

بازديد كنندگان


New Page 1

آموزش HTML >فصل پنجم > درس 16 - زیبا کردن متن

درس 16 - زیبا کردن متن

شما می توانید رنگ و سایز و نوع متن را در HTML تغییر دهید.
اما صبر کنید شما می توانید انواعی از متنهای بالانویس و پایین نویس برای مطالب خنده دار یا ریاضی و شیمی اضافه کنید .
Co2+H2SO4

اهداف این درس

1- عوض کردن سایز بخش مشخصی از یک متن در یک صفحه
2- عوض کردن رنگ مشخصی از یک متن در یک صفحه
3- ایجاد اندیسهای بالا و پایین
4- مشخص کردن نوع قلم

شروع درس

با HTML3,2 و Netscape شما امکانات بیشتری برای ویرایش متن دارید . مخصوصا که می توانید برای فونت خود سایز و رنگ در نظر بگیرید.ویرایش متن می تواند در طرح و نقش صفحه شما تاثیر زیادی داشته باشد اما استفاده بی پروا از آن صفحه ، صفحه شما را دچار تداخل و پارازیت می کند.
شما همچنین می توانید اندیسهای بالا و پایین را برای بیانهای ریاضی و فرمولهای شیمی و پاورقی ها اضافه کنید .
در این درس شما را با اینگونه متن ها آشنا خواهیم کرد و مثالهایی را در این مورد برای شما مطرح خواهیم کرد .

سایز قلم

دستور < font > ....< / font > با Netscape مطرح شد و استفاده می شد برای سایز قلم از 1 تا استفاده می شود 7 از سایز 3 اندازه متن به حالت نرمال در می آید.

رنگ فونت

در درس 14 تگهایی را برای رنگی شدن متن و وارد کردن آن در صفحات وب معرفی کردیم شما همچنین می توانید از تگ فونت برای رنگی کردن قسمتی از متن استفاده کنید . با نوشتن کد رنگ در مبنای 16 یا نوشتن نام رنگ

1- سند Index.html را باز کنید .
2- متن آموزش از راه دور را بصورت زیر ویرایش کنید .

3- نتایج را ذخیره و صفحه را مجددا بار گذاری کنید .

تذکر :

صفات size و color در تگ فونت می توانند همجوار باشند .

اندیسهای بالا و پایین

در زمان HTML3 نمی توانستید در صفحه از بیانات ریاضی و فرمولهای شیمی که نیاز به اندیسهای بالا و پایین داشتند استفاده کنید ، اما بعد از آن از این تگ برای گذاشتن اندیس استفاده شد .
تگ HTML عبارت است از :

1- یکی از اسنادی که قبلا ایجاد کردید را باز کنید .
2- تعدادی معادلات شیمی و ریاضی در آن وارد کنید .
مثلا
HTML3.2 شامل توانایی است که نوع قلم را در صفحه مشخص کند . اما ممکن است در همه مرورگرها کارآیی لازم را نداشته باشد .
قالب HTML آن عبارت است از :

اگر مرورگر بازدید کننده از این توانایی تگ فونت پشتیبانی کند و فونتهایی که در این تگ قرار گرفته در کامپیوترخود داشته باشد در این صورت متن به همان صورت در صفحه وب به نمایش در می آید .
اگر شما قصد داشته باشید که از نوع قلم در تگ فونت استفاده کنید باید از قلمی استفاده کنید که استاندارد باشد و یا بیشتر کامپیوترها آن قلم را داشته باشند.
1- سند index.html را در ویرایشگر خود باز کنید .
2- نوشته زیر را بصورت زیر اصلاح کنید .
3- نتایج را ذخیره و صفحه را مجددا بار گذاری کنید .

مروری بر مطالب

1- چگونه اندازه و رنگ قسمتی از متن را در صفحه تغییر می دهید ؟
2- کدام تگهای HTML را می توانید استفاده کنید اگر مرورگر شما از تگ < font > پشتیبانی نکند؟
3- چگونه یک اندیس پایین در HTML ایجاد می کنید ؟
4- چگونه یک توده ای از متن را با فونت مشخص نمایش می دهید ؟

نکات اضافی

تگ < strik > و< strik / > که در HTML 3.2 در دسترسی قرار گرفته است ممکن است در مرورگر شما کار کند . با این دستور می توانید خطی را بر روی متن ایجاد کنید یعنی متنی که بین دو تگ < Strik > و < Strik /> نوشته شود . در روی آن یک خط کشیده می شود.
در اینجا کلمات ما هرانه ای را برای رنگ متن ذکر می کنیم . در درس 14 شما آموختید که چگونه از تگ < Body > توانائیهای آن برای عوض کردن رنگ زمینه و متن و لینکها استفاده می شود اما اگر برای رنگی شدن قسمتی از متن از تگ < font > استفاده کردیم فقط بر روی رنگ متن های ساده اثر می گذارد و بر روی ابر متنها و اتصالات بی تاثیراست و ممکن است ابر متن ها به طور پیش فرض با خط آبی که در زیر آن گذاشته می شود مشخص گردند.

تمرین

از تمامی تگهای گفته شده در صفحه خود استفاده کنید .


New Page 1

آموزش HTML >فصل پنجم > درس 17 - ايجاد خط

درس 17 - ايجاد خط

اهداف این درس

1- ایجاد خط افقی با قاب متفاوت
2- ایجاد خط با پهنای متفاوت
3- ایجاد خط بدون سایه

شروع درس

سایز خط

اولین مورد این است که خطوطی می تواند با پهنای متفاوت در صفحه ظاهر شوند .

N برحسب Pixel می باشد .
< hr size=2 >same as< /hr > < hr size=8 >

پهنای خط

ویژگی اختیاری دیگری که در تگ < hr > وجود دارد این است که شما می توانید کنترلی بر طول خط داشته باشید که لازم نیست تا کل طول صفحه ادامه داشته باشد .
< hr width=x >
< hr width=z% >
x عددی بر اساس Pixel می باشد که شامل طول خط است و Z در صدی از طول صفحه جاری می باشد که به طور معمول ما درصد را به شما توصیه می کنیم.

طبیعی است که اگر خواستید چندین خط را در وسط قرار دهید هر کدام از آنها در یک خط جداگانه ظاهر خواهند شد . < p > ...< / p alignment=center >
بیشتر مرورگرها از این تگ پشتیبانی می کنند اما ممکن است بعضی از مرورگرها آن را نادیده بگیرند و از آن چشم پوشی کنند .
حال به آرایش صفحه ساخته شده خود می پردازیم :
1- صفحه index.html را باز کنید .
2- بخش زیر را در آن وارد کنید :

و آن را با عبارات زیر جایگزین کنید

بدون سایه
ممکن است شما نخواهید از سایه در خط استفاده کنید .

مروری بر مطالب

1- چگونه می توانید سایز خط افقی را تغییر دهید؟
2- چگونه می توانید طول خط خود را تغییر دهید؟
3- توانایی صفت noshade در تگ hr چیست ؟

تمرین

در صفحات خود از تگ < hr > استفاده کنید.


New Page 1

آموزش HTML >فصل پنجم > درس 18 - Extra Alignment

درس 18 - Extra Alignment

اهداف این درس

1- ردیف کردن قسمتهای مختلف و مجزا کردن قسمتی از متن
2- بوجود آوردن فضای اضافی در اطراف تصویر
3- بوجود آوردن متنهای توضیحی

شروع درس

به ردیف در آوردن متن

با گسترش روز افزون وب نیاز ما برای کنترل بیشتر طرح و شکل صفحه بیشتر شد . یکی از این نیازها وجود تگهایی برای به ردیف در آوردن متن و یا وسط قرار دادن آن و کنترل آن از بقیه قسمتهای صفحه بود که با Netscape و HTML معرفی شد.
مواردی که بین دو تگ < center > و < center / > قرار می گیرد در وسط صفحه به نمایش گذاشته می شود . اگر بخواهید در این زبان کدگزاری متن یا عکسی را در وسط قرار دهید از صفت align در تگ P و Img استفاده کنید .

1- تمامی سندهای خود را باز کنید .
2- برای هر کدام متنی که بین 2 تگ < h1 > و < h1 / > این صفت را به تگ اضافه کنید .

3- نتایج خود را ذخیره و صفحه را مجددا بارگذاری کنید .

تذکر:

در تگ < hr > صفت alignment نیز برای جای دقیق خط می توان بکار برد

به ردیف در آوردن عکس و متن

در درس( a7 ) آموختیم که چگونه یک عکس را در صفحه قرار می دهیم و چگونه در اطراف عکس متن قرار می دهیم .
با صفت align که در تگ < Img > قرار می گیرد می توانید مشخص کنید که یک عکس در چه موقعیتی از بالا و پایین و کناره های صفحه قرار بگیرد ؟

اینک زمانی رسیده که شما بخواهید قسمتی از متن یا دیگر اقلام بکار رفته شده در صفحه را در زیر عکس بیاورید . ویژگی در تگ
وجود دارد که موقعیت را مشخص می کند .

پیشنهاد ما به شما این است که همیشه از این تگ استفاده کنید . زیرا تراز کردن به فونتی که در مرورگر کاربر وجود دارد و همچنین پهنای پنجره مرورگر وابسته است.

لایه عکس

بعضی اوقات هنگامی که از تراز چپ یا راست در عکس استفاده می کنید متن محاصره می شود ، شما می توانید فضای خالی در اطراف عکس ایجاد کنید.

vspace و hspace که مخفف Vertical space و hovizental space می باشند( فضای عمودی و فضای افقی )، فضایی است بر حسب پیکسل که در بالا ، پایین ، چپ و راست عکس گذاشته می شود. صفت Alignment را در صفحه خود اضافه کنید . سند index.html خود را باز کنید . تصویر قرار داده شده در آن ممکن است زیبا به نظر برسد اما فضای خالی در کناره های عمودی آن زیاد است . سپس دستورات زیر را در آن بکار ببرید . توجه داشته باشید که اندازه واقعی وابسته به نوع متنی که برای مرورگر خود انتخاب کردید شما می توانید سایزی که وابسته به سایز انتخابی کاربران می باشد را تنظیم کنید .
این دستورات عبارتند از

روش دیگر استفاده از تگ فونت

وقتی از علامت منفی استفاده می کنید سایز فونت خیلی بیشتر از حد نرمال و متعارف می شود که در این موارد می توان از تگ فوق نیز استفاده کرد.
< basefont size=5 >
با این تغییرات سایز فونت شما از ابتدا 3 درجه بیشتر می شود شما از این دستور هنگامی باید استفاده کنید که از ابتدا فونتی خارج از استاندارد قرار دهید . اگر بخواهید تنظیمی بین بخشهای کوچکی از صفحه داشته باشید باید از تگ بالا استفاده کنید . با استفاده از تگ فوق برای بالاتر از درجه 5 می توانید به راحتی سایز تمام متن را تغییر دهید

تذکر :

تگ < base font > بسته می شود و تا جایی ادامه دارد که تگ < base font> دیگری استفاده شود .
اگر مرورگر شما از این تگ پشتیبانی کرد شما می توانید از دستورات و تگهای HTML3/0 استفاده کنید.

ابتدا تگ < font size=x > را برای آرایش عنوان صفحه استفاده می کنیم .
1- سند index.html را در ویرایشگر متنی خود را باز کنید .
2- در دروس قبل از قالب

برای نشان دادن عنوان صفحه استفاده می کنیم . حال می توانیم از تگ فونت استفاده کنیم .

به آنچه که ما انجام دادیم دقیق نگاه کنید اول سایز A 4 درجه بیشتر از مبنای اولیه ظاهر شد .
بقیه حروف 3 درجه بیشتر از حالت استاندارد و نیز تگهای < b > و < b / > برای برجسته کردن عنوان استفاده کردیم . در پایان چون از تگهای < h1 > تا < h6 > برای شکستن خط استفاده کردیم مجبور به استفاده از تگ

شدیم که عنوان را مجبور به ظاهر شدن در خط جدید کند.
3- اگر خواستیم در جایی از صفحه نقل قولی از کسی داشته باشیم آن را برجسته نشان می دهیم .
4- نتایج خود را ذخیره کنید .
می توانید تفاوت بین استفاده از تگ < font > و < h1 > .... را ببینید


New Page 1

آموزش HTML >فصل پنجم > درس 19 - آرایش در جدول

درس 19 - آرایش در جدول

آرایش در جدول

اهداف این درس

1- آرایش جدول در یک صفحه وب با ردیفهای افقی و عمودی در یک نمایش متن در یک صفحه مشبک
2- یکپارچه کردن عکسها و متون
3- ایجاد جدولی با سلولهایی با رنگهای متفاوت
4- ایجاد جداولی که در زمینه آنها از عکس استفاده شده است .

شروع درس

جداول با HTML3 معرفی شد و بعدها با Netscape گسترش پیدا کرد که آرایش را برای المانها و عناصر در صفحه انجام می داد . یکی از بیشترین استفاده های جدول زمانی است که شما می خواهید ستونی از متن را اضافه کنید .
کدهای HTML برای جداول ممکن است خیلی پیچیده به نظر برسد اما ما با ساخت جداول ساده ای کار را شروع می کنیم .
جداول از انتهای چپ با ستونهایی به سمت راست شروع می شوند . سپس ردیف دوم نیز با چنین ستونهایی ادامه دارد و ...
-- > -- > -- > -- > -- > -- > -- > -- > -- > -- > -- > -- > -- > -- > -- > -- > -- > -- > هر کدام از این خانه های مشبک را یک Cell می نامند .

< b >تگ < Table >< /b >

صفت border در تگ Table به مرورگر می فهماند که یک قابی در دور جدول با ضخامت مختلفی که عدد آن بر حسب pixel برابر با مقدار Border قرار می گیرد ، ایجاد کنید هر سطر با تگهای < tr > ... < / tr > ایجاد می شود و اطلاعات هر ردیف با ستونهای آن که با تگ < td > ... < / td > ایجاد می شود توصیف می گردند .
هر تگ < td > ...< / td > می تواند شامل انواعی از تگهای HTML مثل سرفصلها و ابر متنها و تصاویر خطی و غیره باشد ، صفات زیادی را برای تراز کردن اقلام جدول می توانید به کار ببرید .
< td align=left >aligns all elements to the left side of the cell(this is the default setting) | < td valign=top >aligns all elements to the top of the cell
< td align=right > aligns all elements to the right side of the cell | < td valign=bottom >aligns all elements to the bottom of the cell < td valign=bottom >aligns all elements to the bottom of the cell later, siv. Longhorn dec lared that all markers of cheese would have to be certified befor commencing production
< td align=center >aligns all elements to center of the cell | < td valign=middle >aligns all elements to the middle of the cell(this is the default setting)

ردیف ها و ستون ها

جداول ساده و زیبا و مربع شکل هستند . جدولی که در بالا ذکر شد شامل 3 ردیف ستون و 3 سطر می باشد ، با صفات Colspan و Rowspan چه می توان کرد ؟

تذکر :

صفت استفاده شده برای ستون دوم از سطر اول را با هم تلفیق کرده است ، همچنین می توانیم متن را در وسط هر خانه آرایش دهیم .

در قبل 2 ستون را با هم تلفیق کردیم و بصورت یک سلول واحد در آوردیم . در اینجا می توانیم 2 سطر را با هم تلفیق کنیم و بصورت واحد در آوریم :

اطلاعات یک جدول
1- صفحه lesson2.html را باز کنید .
2- مواردی که بین < pre > ...< / pre > را تماما حذف کنید .
3- این موارد را اضافه کنید :

تذکر : < td >< /tr >< /table >
نگاه کنید به ردیف اول کدها سر فصل جدول تگ< th > و< th / > دقیقا مانند < td > و < td / > عمل می کنند . متنی که بین < th > و < th / > نوشته می شود بطور خودکار بصورت جسم و برجسته به نمایش در می آید .
نام دوره اموزشي | نام مدرس | طول دوره
internet | xxx
html | xxx | 40 h

4- صفحه خود را ذخیره و آن را مجددا بار گذاری کنید .
مواردی را به جدول خود اضافه کنید . توانائیها و صفات دیگری در تگ < table > وجود دارد که باعث آرایش جدول می شود

X ضخامت دیواره خارجی جدول می باشد . صفت Cellpadding فضای خالی بین عناصر جدول از دیواره جدول می باشد . هر چه Y بیشتر باشد خانه جدول بزرگتر خواهد بود . صفت Cellspacing فاصله بین خانه های جدول را تنظیم می کند .
تگ را بصورت فوق در آورید :

1- جدول قبل را بصورت زیر ویرایش کنید .

تگ < caption > نیز مابین تگ های < table > و < table /> قرار می گیرد .
2- برای سرگرمی هر متنی که مابین < th > و < th /> قرار می گیرد را تغییر دهید.

3- سپس جدول را به وسط صفحه انتقال دهید . اگر مرورگر شما از تگ < centert > و < center / > پشتیبانی می کند جدول را با این تگ محاصره کنید .
4- نتایج خود را ذخیره و صفحه را مجددا بار گذاری کنید .
5- در آخر می خواهیم یک ستون به طرف چپ اضافه کنیم . حالا می توانیم یک خانه خالی با اضافه کردن تگ < th > < th / > به ردیف اول جدول اضافه کنیم.

6- حال به ردیف دوم از جدول می رویم و خانه ای که 4 ردیف را در هم ادغام کرده به آن اضافه می کنیم .

جدول سایز خود را با محتویاتی که در خانه های جدول قرار داده می شود تعیین می کند ما چند تگ < br > اضافه کردیم تا از پهن شدن خانه های جدول جلوگیری کنیم شاید بخواهید تحقیق کنید که اگر این تگها را حذف کنیم چه پیش می آید ؟
7- در ردیف 6 جدول خانه ای اضافه می کنیم که به اندازه 2 ستون پهنا دارد.

8- نتایج خود را ذخیره و صفحه بارگذاری کنید .

جدول های غیر قابل روئیت ( خیالی )

جدول همراه با قاب دور برای نمودارها و اطلاعات مربوط به اهداف شما مهم می باشد . اصطلاح خیالی را به این خاطر به کار می بریم که برای خواننده روشن نیست که به یک جدول نگاه می کند . جدول خیالی غیر قابل رویت با همان تگ ساخته می شود با این تفاوت که Border آن صفر قرار داده می شود .
< table border= 0 > تمرین :
جداول خود را با تغییر Border به عدد صفر تغییر دهید . نتایج خود را ذخیره کنید .

جدا کردن لسیتهای طولانی

به عنوان یک تمرین در جداول خود از لیستهای متعدد استفاده کنید .

رنگی کردن جداول

اغلب مرورگرها از رنگی کردن جداول پشتیبانی می کنند.
مکان جدول

به تمامی ردیفها و ستونهای ساخته شده رنگ اضافه کنید .

تذکر :

شما می توانید از عکس به جای پیش زمینه جداول خود و پاورقی در سلولهای آن استفاده کنید . تذکر :
کاربرد ندارد در IE و

شما می توانید تمامی جداولی که ایجاد کردید را بصورتی تغییر دهید که در پس زمینه آن عکس قرار گرفته باشد .

مروری بر مطالب

1- به چه منظوری المانهای یک صفحه را در جدول قرار می دهند ؟
2- چه فرقی بین تگهای < td / > و < td > و < th > و< th / > وجود دارد.
3- صفات Colspan=X و Rowspan=Y به چه منظوری به کار می رود ؟
4- چگونه یک جدول بدون قابیجاد می شود ؟
5- چگونه یک سطر از جدول را رنگی کنیم ؟
6- چگونه یک عکس را پیش زمینه یک جدول کنیم ؟

تمرین :

آموزش داده شده را در صفحات خود بکار ببرید .


New Page 1

آموزش HTML >فصل پنجم > درس 20 - نقشه های تصویری

درس 20 - نقشه های تصویری

اهداف این درس

1- دانستن تفاوت بین فرآیندهای طرف سرور – طرف مشتری
2- ایجاد تصاویری که هر تکه از آن شما را به قسمتی یا صفحه ای هدایت می کند .

شروع درس

در درس( a 7 ) آموختیم که چگونه می توانیم از تصاویر در صفحات وب خود استفاده کنیم . در اینجا می آموزیم که چگونه یک عکس را بگونه ای در آوریم که هر قطعه از آن بصورت اتصالاتی باشد و شما را به قسمتی از همان سایت و حتی سایتهای دیگر هدایت کند. ایجاد یک نقشه تصویری نیاز به یکسری پردازشهایی از طرف وب سرور دارد که چگونگی آن به قرار زیر است :
1- هنگامی که دیدن کننده صفحه را دید و روی عکس خاص کلیک کرد.
2- مرورگر وب می گوید بر روی من کلیک شده و پیامی را برای وب سرور ارسال می کند که بعضی بر روی مختصات عکس کلیک کردند.
3- وب سرور می گوید که من این مختصات را برای عگس گرفتم . فایل HTML که بدنبال پیدا کردن مختصات عکس می باشد می گوید اگر این مختصات بصورت مستطیل باشد دیدن کننده URL مربوطه را برای وب سرور ارسال می کند سپس سرور اطلاعات را به مرورگر ارسال می کند .
4- مرورگر موافقت می کند و سرور می گوید که به URL مذکور برو .
این از فعالیتهای طرف سرور بود که به سادگی و زیبایی این اعمال جدا را از هم انجام می دهد . اما به آن معنی است که برای کلیک بر روی نقشه های تصویری همیشه باید به وب سرور دسترسی داشت .
تگ نقشه های تصویری برای طرف کلاینت بصورت زیر است :

Img.gif نام عکس و map_nam اتصال آن می باشد . HTML file

ویژگی Coords

نواحی داغی که با مختصات x1 و y1 مختصات افقی و عمودی از گوشه بالا سمت چپ و x2 و y2 مختصات افقی و عمودی از گوشه بالا سمت راست را مشخص می کنند .
1- فایل lesson2.html را باز کنید .
2- تغییرات زیر را در روی پان انجام دهید .

3- دستورات HTML را برای مختصات نقشه بکار ببرید .

4- نتایج خود را ذخیره کنید .
5- حال باید صفحاتی را که به آنجا اتصال درست کردیم ایجاد کنیم .
6- صفات خود را ذخیره کنید .

مروری بر مطالب

1- تگهای < map > و < map / > چه عملی را انجام می دهند ؟

تمرین :

در صفحات خود از نقشه های تصویری استفاده کنید .


New Page 1

آموزش HTML >فصل ششم > درس 21 - Meta tag

درس 21 - Meta tag

در این درس مروری بر 2 نوع meta tag داریم.
این meta tag ها در قسمتهای مختلف سند html ایجاد شده است که مرورگر شما آنها را نشان نمی دهد.انواع زیادی از این meta tag ها داریم که فقط به 2 نوع از کاربردی ترین انها اشاره میکنیم.
مکانی که این تگ در انجا قرار میگیرد مابین دو تگ < head > و .. < head / > می باشد.
استفاده از تگ Meta refresh برای جلو رفتن یک صفحه
این meta tag به شما این امکان را می دهد که صفحه وب شما بعد از یک عدد اختیاری (بر حسب ثانیه)به نمایش در اید.و سپس به طور اتوماتیک به به صفحه دیگر و یا حتی URL دیگری برود.
تذکر)به عنوان یک طراح صفحات وب باید کوشش کنید که بینندگان سایت شما پیام Site not Found را دیدین نکنند..
شما از طریق ابر متن ها میتوانید در صفحات وب گردش کنیدو به صفحات دیگر هدایت شویدولی با استفاده از Meta tag ها شما میتوانید به طور اتوماتیک چرخش کنید.
1-صفحه index.html راباز کنید و در آن تغیرات زیر را انجام دهید [image] عددی از ثانیه است که این صفحه بعد ازآن مدت به نمایش در می آید .قبل از انکه به صفحه دیگر با URL دیگر برود.
توجه کنید که تمامی رشته هائی که بعد از CONTENT ظاهرمی شوند باید داخل "" قرار بگیرند. توصیف گر تگ
META تمامی این اعمال سخت را برای درست کردن سایت آموزش از راه دور انجام دادید.حال میخواهید مردم بتوانند آن را از میان میلیونها سایت پیدا کنند.
META TAG در پیدا کردن و شناسائی صفحه شما در هنگام SEARCH کاربران به انها کمک خواهد کرد. به هر حال ما قصد نداریم مطالب پیچیده در ارتباط با موتورهای جستجو گر ایراد کنیم.بعضی برنامه نویسان ماهر کدهائی مینویسندکه این کدها سعی میکنندبسیاری از لینکهای وب را شناسائی کنند. و مقداری اطلاعات راجع به هر صفحه را برگردانندودر DATA BASE متمرکز کنند.کار بران تعدادی لغت توصیفی وارد میکنند اگر سایت شما در DATA BASE موجود باشد به کار بر معرفی خواهد شد.
سایت WWW.MCLI.DIST.MARICOPA.EDU/TUT From www.mcli.dist.maricopa.edu/tut برای سایت فوق بدون داشتن Meta tag موتور جستجو مطالب زیر را می آورد:
Writing HTML /ABOUT/FAQ/ALUMNI/REFRENCES/TAGS/LESSONS/ AUGUST1998/VERSION HISTORY /ABOUT THIS TUTORIAL WRITING HTML WAS CEATED TO HELP TEACHERS CEATING LEARNING…
با وارد کردن Meta tag
نتیجه را بصورت زیر می نویسیم : From:http://www.mcli.dist.marcopa.edu/tut/ More than just an HTML reference,this is a structured approach for learning how to create web pages , designed by specialists in learning at the Maricopa Center for Learning & Instruction قالب html برای اضافه کردن این meta tag بصورت زیر است

اگر در حالت ایجاد یک متن توصیفی هستیدباید توجه داشته باشید که ماکسیمم طول این meta tag نباید بیشتر از1024 کاراکتر باشد.

مروری بر مطالب

1-برای اینکه صفحه شما به طور اتوماتیک به صفحه دیگر برود چه باید کرد؟
2-چگونه از تگ meta refresh برای ایجاد 10 ثانیه وقفه و رفتن به صفحه دیگر استفاده میکنید؟
3- چگونه از Meta tag برای افزایش شانس در پیدا شدن صفحه خود در موتورهای جستجو گر استفاده می کنید

تمرین :

در صفحه خود از این دو نوع meta tag استفاده کنید


New Page 1

آموزش HTML >فصل ششم > درس 22 - پنجره Target

درس 22 - پنجره Target

اهداف این درس

1- ساختن یک ابر متنی که که با باز شدن آن صفحه جدید در پنجره ای جدید به نمایش در آید .
2- نوشتن قالبی برای HTML بطوریکه تمامی اتصالات در این صفحه مشخص بار گذاری شود .
3- محدودیت در باز شدن پنجره های متعدد.

شروع درس

برای تمامی صفحاتی که بر روی آن کار می کنیم اسنادی داریم که بر روی آنها ابر متن وجود دارد که با کلیک بر روی آنها صفحه جدید بارگذاری می شود و جایگزین مورد قبل می شود . بازدید کننده می تواند با استفاده از دگمه Back بر روی نوار ابزار به صفحه اول باز گردد.
اما ویژگی وجود دارد که برای باز شدن اتصال در یک صفحه جدید به آن نیاز دارید. در این درس ما به تغییرات در تگ < a href > برای مشخص کردن بارگذاری در پنجره ای جدید در مرورگر می پردازیم .
قبل از شروع باید نکاتی را در نظر داشته باشید . اگر مرورگر شما پنجرهای زیادی بصورت باز شده داشته باشد ممکن است دیدن کننده گمراه شود که کدامیک اول باز شده است . پنجره بعضی از مرورگرهای کامپیوتر کاملا مبهم است و نمی توان فهمید کدام پنجره اول باز شده است ؟

صفت TarGet

کد HTML که ما برای Target استفاده می کنیم بصورت زیر است :

در دروس قبل آموختیم که Href اشاره به یک URL دیگر یا یک صفحه وب دیگر دارد . قسمت دیگری از یک تگ نام آن می باشد که ما برای آن ایجاد می کنیم . ما می توانیم یک نام برای Target ایجاد کنیم که معین کننده هویت داخل مرورگر است . با کلیک بر روی یک اتصال چه اتفاقی می افتد ؟

مرورگر شما می گوید که من باید برای این آدرس یک HTML بگیرم http://www.mcli.dist.maricopa.edu/tut/likethis.html و آن را در یک پنجره به نام tutorial جایگیری می کند و چون چنین پنجره ای موجود ندارم یک پنجره جدید ایجاد می کند .
مقادیری که شما می توانید در Target بکار ببرید بصورت زیر است :
1. _Top
3._blank
2. _self

4. _parent که هر کدام معنی خاصی را دارند . بکار بردن مقدار _blank : زیان استفاده از این تگ این است که اگز شما 20 اتصال داشته باشید که تماما Target آنها هم نام باشند پنجره هایی زیادی ایجاد می شود که ممکن است سیستم شما را دچار مشکل کند .

مروری بر مطالب

1- چگونه یک اتصال را مجبور به باز کردن صفحه در صفحه ای جدید می کنید ؟
تمرین
تگهای گفته شده دراین درس را در صفحات خود بکار ببرید.


New Page 1

آموزش HTML >فصل ششم > درس 23 - فریم کردن صفحه

درس 23 - فریم کردن صفحه

اهداف این درس

1- ایجاد یک صفحه وب با قالبهای متفاوت
2- ایجاد اتصال از یک فریم به قسمتی دیگر از فریم دیگر
3- ایجاد ابر متن هایی که صفحه را کامل از بین ببرد و بعد صفحه دوم را ایجاد کند .
4- ویرایش و صفات حاشیه بندی فرمها

شروع درس

آیا شما تا به حال صفحاتی دیده اید که از قابهای متعدد در آن استفاده شود ؟ فرم صفحه را به 2 سند HTML جداگانه تقسیم می کند که معمولا 2 فرم بصورت متحد با یکدیگر عمل می کنند . در صفحات فرم دار از ابر متن ها نیز استفاده می کنند .
بعضی اوقات در اثر کلیک بر روی لینکها فرم قبلی کاملا از بین می رود و فرم جدید ایجاد می شود ، بعضی اوقات صفحه جدید بر روی همان فرم قبلی ایجاد می شود .

اشکالات فرمها

در صفحاتی که از اسناد متعدد در آن استفاده شده کاربران در هنگام بار گذاری صفحه و نیز در هنگام گرفتن پرینت از صفحات وب با مشکل مواجه می شوند .

ااساس فرم

صفحه ای که در آن از فرم استفاده می شود شامل یک سند اصلی HTML است که آن را برنامه کار می نامند . برای طرح و شکل و به ردیف در آوردن فرمها از صفت استفاده می شود . هر کدام از قابهایی که در یک صفحه فرم از آنها استفاده شده است خود یک سند HTML جداگانه دارند . در ابتدا باید بدانید که صفحه چگونه تقسیم می شود و به هر قاب چقدر فضا اختصاص داده می شود ؟
در قدم اول باید بدانید که صفحه از سطر یا ستون تشکیل شده است
نگاه کنید به مثال 1- که صفحه از 2 سطر و در مثال 2 صفحه از 2 ستون و مثال 3 که صفحه از 2 سطر و 2 ستون تشکیل شده است . در مثال 5 شما 3 سطر مشاهده می کنید که در وسط این سطرها 2 ستون قرار گرفته است و در مثال 6 سطر اول به 2 ستون تقسیم شده است .
حال به دقت به مثال 7 دقت کنید .سطرها و ستونها ایجاد frameset می کند . قالب HTML ایجاد صفحات به صورت زیر است :

تذکر :

هر Frameset معرف و تعریف کننده یک سری سطر یا ستون است

مقادیر X و Y و ... اشاره بر مقداری فضایی دارد که به هر سطر یا ستون اختصاص داده می شود یا بر حسب در صدی از پنجره مرورگر می باشد . برای هرستون ابعاد وابسته به یک سند HTML مشخص است که در قسمت
< =Frame src >
ذکر شده است . مرورگرهایی که نمی توانند قابها را نشان دهند مواردی که بین < Frameset > و < Frameset / > نوشته شده است را نادیده می گیرند و از جهت دیگر مرورگرهایی که امکان نمایش قابها در صفحه را دارند مطالبی که بین < Noframes > و < Noframes /> نوشته شده را نادیده می گیرند .
اعدادی که باید در تگ به جای مقدار Cols و Rows قرار دهید بر حسب پیکسل و یا درصد می باشد .
Source HTML مثال (1)

Sourece مثال 7

تذکر :

این صفحه وب نیاز به 6 سند HTML برای نمایش دارد . دستورات گفته شده برای مرورگرهای با ورژن بالا صادق است . در قسمت بالای فرم Navigation bar قرار گرفته که برای اتصال به صفحات دیگر سایت از آن استفاده می شود . قسمت پایین قاب شامل پاورقی صفحه و نیز اتصالات دیگری که باید در همان قاب جابه جا شود می باشد . در قاب دست چپ در وسط سطر شامل لینکهایی است که باید مطالب آن در همان قاب بارگذاری شود . در فرم دست چپ در میان سطر شامل ابر اتصالاتی است که شامل 3 قسمت متفاوت اصلی در صفحه است . که مطالب آنها باید در قاب راست بارگذاری شوند . این طراحی به ما اجازه می دهد که صفحه اصلی را به مقادیر گسسته تقسیم کنیم .

مروری بر مطالب

1- به چه منظور از تگ < frameset > و < frameset /> استفاده می شود ؟
2- چند سند HTML برای یک صفحه با 3 قاب افقی و 2 قاب عمودی لازم است ؟
3- چگونه اتصالاتی می توان ایجاد کرد که اطلاعات از یک قاب بر روی قابی دیگر بارگذاری شود ؟

تمرین :

تگهای ذکر شده را در صفحات خود بکار ببرید .
تذکر :

برای اینکه به کاربران اجازه داده شود که بتوانند با کشیدن دکمه ماوس سایز قابها را نیز تغییر دهند از Noresize استفاده می شود .

دوره هاي آموزشي

آموزش فتوشاپ
آموزش HTML
 آموزش اینترنت - مهارت هفتم از ICDL
آموزش مباحث پيشرفته در طراحي صفحات وبjavascript - SQL - ADO
لیست اسناد و منابع اینترنتی
آموزش متدولوژی و تکنولوژی طراحی وب CIW
 مفاهیم Java و Active-x
 آشنایی با مفاهیم و اصطلاحات اینترنتی
 مفاهیم پایه فن آوری اطلاعات - مهارت اول از ICDL
آموزش سیستم عامل ویندوز 98 - مهارت دوم از ICDL
آموزش Word - مهارت سوم از ICDL
 آموزش Power Point -مهارت ششم از ICDL
مقدمه ای بر ویروسها و برنامه های مخرب
 آشنایی با Access - مهارت پنجم از ICDL
آموزش Flash-MX ( مقدماتي)
 كد نويسي با جاوا اسكريپت
آموزش Excel2000 - مهارت چهارم از ICDL
آموزش مهارت رفتاري

بازديد كنندگان


New Page 1

آموزش HTML >فصل ششم > درس 24 - اضافه کردن فرم به صفحات وب

درس 24 - اضافه کردن فرم به صفحات وب

اهداف این درس

1- توصیف استفاده های فرمها در صفحات

شروع درس

فرمها چه هستند ؟ یقینا تا به حال آنها را در صفحات خود دیده اید . فرمها برای اضافه کردن موارد آموزنده در صفحه مورد استفاده قرار می گیرند و اجازه ارتباط کاربران با سایت شما را ممکن می سازند . برای جمع شدن اطلاعات نقش فرمها در جمع آوری انواع مواردی است که کاربران در داخل میدانهای متنی در مرورگر و منوها قرار می دهند و کلیدهای رادیوئی نیز باید در صفحات برای انتخاب موارد فرم جایگزین شوند.
مرورگرها این اطلاعات را می گیرند و آن را با بسته هایی با فرمتهای قابل ارسال در وب سرور پنهان می کنند . در اینجا برنامه های که منتظر اطلاعات فرمها می باشدوجود دارند این برنامه ها اطلاعات فرمها را از حالت مخفی بیرون آورده و بر آنها نظارت کرده و آنها را ذخیره و سپس به دیدن کننده برمی گردانند . در درس بعدی شما خواهید آموخت که چگونه این فرمها را ایجاد کنید .

مروری بر مطالب

1- فرمها چگونه مورد استفاده قرار می گیرند ؟
2- کجا فرمها را می بینید و از آن استفاده می کنید .


New Page 1

آموزش HTML >فصل اول > درس 2 - ویرایش یک سند HTML

درس 2 - ویرایش یک سند HTML

شما اولین سند HTML خود را ایجاد کردید . در این درس خواهید آموخت که چگونه با سرعت ، تغییراتی در سند خود ایجاد کنید و تغییرات را در مرورگر خود ببینید. بعد از آموزش این درس توانائیهای زیر را خواهید داشت :
1- ایجاد یک محیط کاری
2- تغییرات در سند HTML
3- اجرای سند مرورگر برای دیدن تغییرات

ایجاد دوباره محیط کاری

برای تکمیل این درس شما نیاز به ایجاد یک پنجره مرورگر دوم و پنجره Editor متنی که در درس 1 استفاده کردید دارید.
1- یک پنجره جدید از مرورگر. به وسیله انتخاب گزینه New Window از منوی File .
2- از گزینه Open برای باز کردن سند HTML که در قبل ایجاد کردید استفاده کنید.
3- Editor متنی خود را دوباره باز کنید .

انجام تغییرات در سند HTML
1- وارد شدن در پنجره Edit ویرایشگر متنی
2- متن زیر را در درس قبل وارد کنید .
"در اینجا شما با یک سایت آموزشی – آموزش از را دور روبرو هستید
امیدواریم از این سایت لذت ببرید "
نکته :
این متن بالای تگ < body / > و < html / > باشد.
بین < body > و < body / > نوشته می شود .
3- از منوی فایل ، با انتخاب گزینه Save تغییرات خود را ذخیره کنید .

باز کردن سند در مرورگر

به محیط کاری مرورگر خود بازگردید . جایی که فایل قبلی شما نمایش داده شده است . توجه داشته باشید که متون جدیدی که شما وارد کردید، هنوز قابل رویت در پنجره شما نیست . برای دیدن این تغییرات از کلید Refresh استفاده کنید . در این صورت هر تغییری که ایجاد کرده اید را مشاهده می کنید .
ذکر این نکته ضروری است که مرورگر وب از کلیه فاصله ها و کاراکترهای خالی که در سند وارد کردید چشم پوشی می کند .
البته مشخص است که زمانی می رسد که شما نیاز دارید که جاهای خالی در سند خود را مابین پاراگرافها استفاده کنید که در درس 4 این مطلب را می آموزید . شما می توانید فایل خود را در Desktop ذخیره کنید و از همانجا به اجرا در آورید .

آزمایش

سند ایجادی خود را با سند نمونه مقایسه کنید، اگر صفحه شما با نمونه متفاوت بود دوباره مروری بر مطالبی که در ویرایشگر متنی وارد کردید داشته باشید.

مروري بر مطالب

1- چگونه محیط کاری را باز کردید.
2- چه مراحلی را برای ایجاد تغییر دنبال کردید.
3- چگونه تغییرات را در سند خود مشاهده کردید.

تمرین :

با توجه به مطالبی که در آموزش دیدید سندی که در درس قبل ایجاد کردید تغییر داده و سپس تغییرات خود را مشاهده کنید .


New Page 1

آموزش HTML >فصل ششم > درس ٢٤-ب - بوجود آوردن فرم ها

درس ٢٤-ب - بوجود آوردن فرم ها

بوجود آوردن فرم ها درس 24/a

اهداف این درس

1- ایجاد میدانهای متنی
2- میدانهایی برای وارد نمودن Password
3- میدانهایی برای ایجاد
Email 4- دکمه های رادیویی
5- دکمه ها
6-ايجاد checkbox
7- منوهای انتخاب شونده

شروع درس

در این درس به معرفی اساس و اجزاء فرمها می پردازیم .
فرمها در صفحه وب با < form > ....< /form > تعریف می شوند . کلیه اجزاء فرمها مثل میدانهای متنی ، کلیدها و ... در بین این 2 تگ قرار خواهند گرفت که قالب HTML آن بصورت زیر است :

ارزش Action یا مقداری که در آن قرار می گیرد موقعیت برنامه یا اسکریپتی است که می خواهد فرآیندی بر روی اطلاعات ارسال شده توسط کاربر را انجام دهد. و صفت Method دارای 2 مقدار Get و Gost می باشد. که آن نیز معرف 2 روشی است که اطلاعات باید برای نرم افزار پردازش کننده ارسال شود . تمامی اجزاء داخل تگ < form > اطلاعات که درون آنها می باشد را ارسال می کنند . هر جزء شامل type می باشد .
برای ایجاد میدانهای متنی که دیدن کننده بتواند درون آنها تایپ کند ، طول پیش فرض است که 20 کاراکتر می باشد . ولی شما می توانید میدانهایی با سایز های دیگر ایجاد کنید . شما می توانید با قرار دادن صفت Maxlenght برای آن یک حد تعریف کنید . متن داخل میدانها هنگام بارگذاری صفحه خالی می شود مگر آنکه شما برای آن رشته متن را در صفت Value تعریف کنید .
ظاهر آن مانند میدان متنی است با این تفاوت که وقتی کاربر درون این میدان تایپ می کند به جای نمایش کاراکترها نقطه یا ستاره نمایش می دهد . میدان متنی Password در هنگام ارسال کوشش به جلو رفتن می کند و بعد از رساندن اطلاعات به سرور کوشش آنها پایان می پذیرد .
Character wide.
میدانهایی که چندین خط دارند و دیدن کننده برای دیدن متن از Scroll استفاده می کند. تگ تعریف کننده سایز میدان به وسیله اعدادی که در صفات Cols و Rows وارد می شوند تعریف می گردند با وارد کردن خصیصه Wrap=Virtual متنی که وارد این میدان می شود ، بطور اتوماتیک شکسته می شود . شما همچنین می توانید متنی را بطور پیش فرض در آن داشته باشید .

کلیدهای رادیوئی (type="Radio")
کلیدهای رادیویی کلیدهایی هستند که از یک گروه کلید همزمان فقط یکی از آنها را می توان انتخاب کرد و اگر یکی از آنها را کلیک کردید و سپس دیگری را کلیک کردید دکمه اول از حالت انتخاب خارج می شود . یک گروه از دکمه های هم رده با گذاشتن یک نام مشترک برای همه آنها بوجود می آیند و مقداری که فرستاده می شود برابر است با مقداری که توسط دکمه رادیویی انتخاب شده است . با گذاشتن خصیصه Checked درآخر تگ یک دکمه این دکمه بصورت پیش فرض در هنگام بارگذاری صفحه انتخاب می گردد.

تذکر :

کلیدهایی که اسم های جداگانه دارند بصورت مستقل از هم عمل می کنند .

این گونه کلیدها شبیه به کلیدهای رادیوئی عمل می کنند اما تحت تاثیر کلیدهای دیگر نیستند . بنابراین شما می توانید بیشتر از یک مورد انتخاب در یک گروه کلید شبیه به هم داشته باشید . توجه کنید که هر Checkbox اسم منحصر به فرد دارد . اگر یک Checkbox علامت نخورده باشد با گذاشتن دکمه ماوس بر روی جایی از پهنای آن و کلیک کردن آن می توانید آن را به حالت انتخاب در آورید و نیز دوباره بر روی آن می توانید آن را از حالت انتخاب خارج کنید . مقداری که برای سرور ارسال می شود برابر با ارزش مقداری است که کنار Checkbox قرار گرفته است اضافه کردن خصیصه Checkbox در این تگ باعث می شود آن مورد بطور پیش فرض انتخاب گردد .

منوهای انتخاب شونده به کاربران این امکان را می دهد که از بین انتخابهای متعدد یکی را انتخاب کنند و تگ تعریف آن < option > و < option / > می باشد .
مقدار این ویژگی در هنگام پردازش بازگردانده می شود با اضافه کردن ویژگی Selected در این تگ این جزء در هنگام بارگذاری صفحه بصورت پیش فرض انتخاب می گردد . اگر چنین ویژگی را به کار نبرید اولین مقدار منو بطور پیش فرض انتخاب می گردد.

به دنبال ایجاد دکمه ها و فرم ها کلید Submit به مرورگر اجازه می دهد که تمامی موارد انتخابی شامل منوهای انتخاب شده ، متنهای وارد شده و ... را جمع آوری و آنها را به جایی که مکان آن در صفت Action آورده شده است ارسال کند و کلید Reset فرم را به حالت اول بر می گرداند .

مروری بر مطالب

1- ساختار یک فرم چیست ؟
2- تفاوت میان کلیدهای رادیول و Checkbox در چیست ؟
3- چگونه منوهای بازشونده در صفحه ایجاد کنیم ؟
4- فرق بین کلیدهای Submit و Reset در چیست ؟

تمرین :

موارد گفته شده و کلیه فرم ها را در صفحات ساخته شده خود به کار ببرید .


New Page 1

آموزش HTML >فصل ششم > درس 25 - چند رسانه ای در صفحات شما

درس 25 - چند رسانه ای در صفحات شما

اهداف این درس

1- در نظر گرفتن فاکتورهایی برای ایجاد چند رسانه ای
2- در هنگام چند رسانه ای کردن صفحه چه مواردی را باید برای بازدیدکنندگان در نظر گرفت ؟

شروع درس

تا شروع سال 1993 صفحات وب محدود به متن و چند عکس بودند . امروزه جذابیت و گیرایی زیادی در صفحات بوجود آمده است . می توانید از انواع رسانه ها نظیر کارتون ، ویدئو ، انیمیشن ، حرکات چرخشی ، صدا ، فرمهای بر هم کنشی استفاده کنید . قبل ازاعمال این رسانه ها ، باید دقیقا در نظر بگیرید که چه ارزشی را دارید به صفحه اضافه می کنید .مثلا وجود انیمیشن رقص ممکن است در ابتدا جذاب به نظر برسد ولی با مرور زمان با نگاه کردن به آن ممکن است حواس شما را پریشان کند .
پس سئوالی که به نظر شما می رسد این است که آیا اضافه کردن موارد (sound , video, … ) به صفحه مهم است ؟ در جواب این سئوال ...

هنگامی که شما تصمیم به اضافه کردن چند رسانه ای در صفحه وب خود می کنید در ابتدا باید در نظر بگیرید چه زمانی صرف می شود تا شما اینگونه رسانه ها را ایجاد کنید .
از موارد دیگری که باید در نظر گرفت بازدیدکنندگان می باشند . شما باید از خودتان بپرسید اجراء رسانه ای که در صفحه ایجاد می کنید به چه عاملیتهایی نیاز دارید ؟
و زمانی که سپری شود تا کاربر آن نرم افزار را بر روی سیستم خود نصب کند و سپس سیستم را Restart کند ممکن است سایت شما را فراموش کنند. مطلب بعدی دیگر این است که چه زمانی طول می کشد که صفحه برای کاربر بارگذاری شود . کاربرانی که مجبور به برقراری ارتباط با مودم هستند ممکن است برایشان مقدور نباشد که با صفحه شما ارتباط برقرار کنند ، شما برای اضافه کردن ویدئو به صفحه خود نیاز به استفاده از مرورگرهای ویژه دارید.

مروری بر مطالب

1- برای اضافه کردن چند رسانه ای چه مواردی را در هنگام استفاده از رسانه ها باید در نظر گرفت ؟
2- در نظر گرفتن مواردی که کاربر برای بارگذاری به آن احتیاج دارد برای گرفتن اطلاعات بیشتر می توانید به این دو سایت مراجعه کنید :
http://wdvl.com/md timedia http://www.mcli-dist.maricopa.edu/authoring


New Page 1

آموزش HTML >فصل ششم > 25 -ب - اضافه کردن فیلم و صوت -multimedia

25 -ب - اضافه کردن فیلم و صوت -multimedia

1- مشخص کردن فرمتهایی که برای فیلم از آن استفاده می شود .
2- مواردی که برای دیدن فیلم به آن نیاز دارید
3- نوشتن کد HTML برای گذاشتن فیلم در صفحه
Real video و Quick time نیاز به مرورگرهای Plug in دارند . خوشبختانه اکثر مرورگرهای امروزی از این تکنولوژی حمایت می کنند اما بعضی اوقات باید به روز شوندو این به دلیل آن است که ویدئو به پهنای باند زیادی احتیاج دارد. اگر شما بخواهید به عنوان یک طراح از ویدئو در صفحات خود استفاده کنید که با کلیک بر روی آن فیلم به نمایش در بیاید باید به چند تذکر توجه کنید که در این درس بیان خواهیم کرد . برای استفاده از ویدئو در صفحات خود باید از تگ < EMBED > استفاده کنیم که به نوعی شبیه به تگ < IMG > عمل می کنید .
< EMBED src="video.mov" width="320" height="240" > < /Embed >
موارد دیگری که باید رعایت کرد
توصيه | ارزش | ويژگيهاي embed
نياز به آدرس کامل فايل داريد | مسير فايل ويدئو | SRC
فيلم يا بطور اتوماتيک به نمايش در مي آيد يا کاربر بايد بر روي دکمه کليک کند | ابعاد فيلم true/false | Width height
فيلم کنترل بار را در بالاي صفحه ايجاد کند يا خير | True / false | Controller
با کليک بر روي فيلم محل براي ديدن کننده ارسال شود | URL | href
به مرورگر اجازه مي دهند فيلم را در پنجره جديد نشان دهد | نام پنجره | Target
فيلم در حلقه تکرار شود | True/false | Loop
براي کاربر ارسال شود Quicktime در صورت نداشتن | URL | Plug in spage

مروری بر مطالب

1- قالب HTML برای گذاشتن ویدئو در صفحه چیست ؟
2- چه ویژگیهایی در تگ < EMBED > آورده می شود و برای اینکه ویدئو به طور اتوماتیک بارگذاری شود چه باید کرد ؟

اطلاعات اضافی

متاسفانه اکثر اوقات این قالب فیلم در صفحات گیرایی لازم را ندارد و Quick time همیشه فرمت خوبی نیست و می توان از 2 فرمان دیگر AVI و MPEG استفاده کرد.


New Page 1

آموزش HTML >فصل ششم > درس 25 - ج - قالبهاي صوتي مورد استفاده

درس 25 - ج - قالبهاي صوتي مورد استفاده

اهداف این درس

1- از چه قالبهایی برای گذاشتن صدا در صفحات وب استفاده می شود ؟
2- مواردی که در هنگام گذاشتن صوت در پنجره باید رعایت کرد چیست ؟
3- نوشتن یک کد HTML برای گذاشتن صدا در صفحه.

شروع درس

Sound یکی از روشهای خوب برای رسیدن اطلاعات به کاربر می باشد و شما در بیشتر از سایتهای وب می توانید از این امکان استفاده کنید. سئوال این است که چه وقت صدا مفید است ؟ Audio برای ( سخنرانیها ، اخبار و رویدادهای مهم و ... ) مورد استفاده قرار می گیرد و اغلب از پهنای باند کمی استفاده می کند . صدا مانند ویدئو باید از آنالوگ به دیجیتال تبدیل شود . فرمتهای مختلفی برای صداگذاری در صفحه وجود دارد . بعضی از انواع آن عبارتست از :
MIDI , AV , AIFF , LWA , MP3 , ... فرمت ویژه ای بنام MIDI وجود دارد که حجم آن بسیار کم است و نسبت به فایلهای wave ترجیح دارد . برای قرار دادن صدا در صفحه وب از تگ فوق استفاده می شود .

چگونه می توان یک فایل صدا در صفحه قرار داد که در هنگام بارگذاری صفحه بدون اینکه نرم افزار خاصی اجرا شود شروع به پخش صدا شود ؟

مروری بر مطالب

1- انواع فرمتهای صدا که در صفحه بکار می رود را بیان کنید .
2- برای گذاشتن صدا در صفحه از چه کدی استفاده می شود ؟
3- چگونه فایل صدا را برای تکرار متناوب در حلقه قرار دهیم .


New Page 1

آموزش HTML >فصل اول > درس 4 - شکستن پاراگراف

درس 4 - شکستن پاراگراف

اهداف این درس

1- شناختن تگهایی که ایجاد پاراگراف می کند .
2- کپی کردن متن از یک صفحه وب و انتقال آن به سند دیگر
3- شکستن پاراگرافها در سند HTML خود و مشاهده تغییرات

شروع درس :

در درس قبل گفتیم که مرورگر وب شما از تمامی فضاهای خالی که در ویرایشگر در هنگام ایجاد سند وارد نمودید ، چشم پوشی می کند . اما هنگامی که مرورگر تگ زیر را مشاهده کند مجبور به ایجاد یک پاراگراف می شود .
< p />این تگ باعث ایجاد پاراگراف جدید می شود
< p > در درسهای بعدی خواهید دید که چرا باید از تگ < p /> نیز استفاده کرد .
همچنین < br > یک خط خالی ایجاد می کند . بنابراین نیازی نیست که تگ چک شود .

وارد کردن پاراگراف جدید و شکستن خط

1- باز کردن محیط کاری
2- رفتن به پنجره ویرایشگر متنی
3- باز کردن سند (lesson1.html)
4- برای انتقال دادن جملات از موس استفاده کنید .
شما در این قسمت سایت آموزش از راه دور (Training the web) را دنبال خواهید کرد و در این درس می آموزید که چگونه پاراگراف جدید ایجاد کنید یا فاصله ای ایجاد کنید .
5- حال به سند html خود باز گردید و این متن را در آنجا انتقال دهید .
6- تغییرات خود را دخیره کنید .
7- به مرورگر خود باز گردید .
8- اگر سند کاری شما باز نیست می توانید از منوی File ، گزینه Open استفاده کنید . (طبق قبل)
9- پنجره جاری را برای دیدن تغییرات Refresh کنید .
10- به سند ویرایشگر متنی باز گردید .
11- دوباره تگهای زیر را به جملات اضافه کنید .
< h2 / > آموزش از راه دور < h2 >
شما در این قسمت از سایت آموزش از راه دور را دنبال خواهید کرد . < P > در این درس می آموزید که چگونه یک پاراگراف جدید و فاصله ایجاد کنید .
12- تغییرات خود را ذخیره کنید .
13- به مرور گر خود باز گردید و Refresh کنید و نتایج تغییرات را مشاهده کنید.

صورتهای دیگر شکستن پاراگراف

از روشهای دیگرایجاد پاراگراف استفاده از خطوط افقی یا تگ hr می باشد .
شما می توانید یک خط راست و مستقیم ایجاد کنید . قالب عمومی html برای ایجاد خط تگ < hr > می باشد .
در آخر تگ < Br > مجبور می شود که متن شکسته شود مانند < p > بدون اینکه نیاز به وارد کردن خط خالی داشته باشید . تگ < br > مانند تگ < p > متن را مجبور به ظاهر شدن در خط جدید می کند . شما از این تگ در هنگام نوشتن اشعار و غیره استفاده می کنید .

مثال

HTML RESULT
And in the end it was all for naqught < p > < b >the new cheese edict< /b > < Br > later, siv. Longhorn dec lared that all markers of cheese would have to be certified befor commencing production And in the end it was all for naqught

the new cheese edict
later, siv. Longhorn dec lared that all markers of cheese would have to be certified befor commencing production

And in the end it was all for naught < h4 > the new cheese edict < /h4 > later , sir lenghorn . declared that all makers of cheese would have to be certified befor commencing production And in the end it was all for naught

the new cheese edict

later , sir lenghorn . declared that all makers of cheese would have to be certified befor commencing production

مروری بر مطالب

1- تگهای HTML برای شکستن خط و ایجاد پاراگراف چه هستند ؟
2- چه مراحلی را برای ایجاد تگها دنبال خواهید کرد ؟
3- چگونه می توانید تغییرات خود را ببینید ؟

تمرین

از تگهای < Br > , < hr > , < p > در سند خود استفاده کنید .


New Page 1

آموزش HTML >ضمیمه > معرفی منبع - تماس با نویسنده

معرفی منبع - تماس با نویسنده

منبع : ترجمه ی سایت آموزشی HTML


New Page 1

آموزش HTML >فصل اول > درس 3 - نشانه گذاری 6 درجه

درس 3 - نشانه گذاری 6 درجه

اهداف این درس :

1- شناسایی درجات مختلفی از نشانه گذاری در HTML و تگهای مربوط به آن
2- گذاشتن درجات مختلف نشانه گذاری در سند و مشاهده تغییرات در مرورگر

شروع درس

نشانه گذاری عنوانگذاری HTML

< hn / > متن شما به این سایز ظاهر می شود < hn >
n عددی است از 1 تا 6

مثال

در اینجا این نوشته 6 درجه مختلف دارد . درجات این نشانه گذاری مابین درجات 1 تا 6 می باشد و در خارج از این رده تناقض دارید ،

جایگذاری عنوان ها در سند HTML

تذکر : اگر محیط کاری ندارد طبق آدرس قبل ایجاد کنید .
1- محیط کاری باز کنید ( اگر هنوز باز نشده است )
2- به پنجره ویرایشگر متنی بروید .
3- پنجره HTML که در درس 2 ایجاد کردید را باز کنید .
4- این تگها را برای بزرگترنمایش دادن titlebar استفاده می کنیم .
< h1 > lesson1 < / h1 >
5- مطالب زیر را وارد کنید
درس 3 :

6- تغییرات خود را ذخیره کنید .
7- به پنجره مرور گر باز گردید و سند را باز و Refresh کنید .

آزمایش

سند خود را با سند نمونه مقایسه کنید اگر بعضی ازنشانه گذاری ها اعمال نشده بود دوباره تگهای مربوط را اصلاح کنید .
از اشتباهات معمولی که در هنگام کار عملی در این درس پیش می آید عدم استفاده از در نشانه گذاریها است .
< h1 > lesson1 < h1 > علامت اسلش فراموش شده است اگر / در تگ فراموش شود . مرور گر آن متن را با این درجه نشان نمی دهد و برای اصلاح دوباره باید به سند باز گردید .

مروری بر مطالب

1- درجه های مختلف نشانه گذاری حروف چه هستند ؟
2- تگهای مرتبط با این درجات نشانه گذاری چه هستند ؟
3- چه مراحلی را بایدبرای ایجاد متون با سایزهای مختلف دنبال کنید .
4- اگر / را فراموش کردید چه باید کنید ؟

تمرین :

در سند HTML خود از 3 درجه نشانه گذاری استفاده کنید.


New Page 1

آموزش HTML >فصل دوم > درس 5 - سبکهای مختلف نوشتاری

درس 5 - سبکهای مختلف نوشتاری

< b >< I >< tt >
HTML می تواند به مرورگر بفهماند که قسمتهایي از متن را بصورت ضخیم و یا ایتالیک درآورد .

اهداف این درس

بعد از آموزش این درس
1- تگهای ضخیم و یا ایتالیک و .... به شما شناسانده خواهد شد
2- متون خود را در سند HTML به سبک های مختلف وارد کنید و سپس آن را در مرورگر مشاهده کنید .

شروع درس

HTML طرحهای مختلفی را در ارتباط با سبک های مختلف نوشتاری به شما می دهد، به مثالهای زیر توجه کنید .
HTML | RESULT
< b > this is bold - < /b > < I > this is italic < /I > < tt > this is typewriter < /tt > | this is bold - this is italic this is typewriter
< I >< b >this is bold and italic< /b > < /I > < b >< I > and so is this < /I >< /b > | this is bold and italic and so is this
Blah < h2 >< I >< new >< /I > and < tt >improved Blah Blah < /tt >< /h2 > blah blah Blah

and improved Blah Blah

blah blah

سبک های مختلف متن را در سند HTML خود وارد کنید .
اگر محیط کاری ندارید باز کنید مراحل زیر را دنبال کنید .
1- محیط کاری خود را دوباره باز کنید .
2- سند خود را که به نام lesson1.html ذخیره کردید باز کنید .
3- لغت آموزش را از درون آن پیدا کنید حال می خواهیم آن را ضمیمه کنیم .
4- تگ مرتبط با عمل فوق را وارد کنید . < b / > آموزش از راه دور < b >
5- حالا پاراگراف دوم را با صورت ضخیم و ایتالیک درآورید.
برای اینکه تاکید بیشتری روی قسمتی از متن داشته باشید بوسیله تگ های < I >, < /b > , < b > می توانید این تاکید را انجام دهید .
6-برای اشاره به قسمت خاصی از متن مثل نام نویسنده ، می توانید از تگ
< tt > , < / tt > استفاده کنید .
7- تغییرات خود را ذخیره کنید و مجددا مرورگر خود را باز کنید .

آزمایش

عملیات خود را تست کنید

مروری بر مطالب

1- تگهای سبک های نوشتاری چه هستند ؟
2- انواع تگهای مختلف برای سبکهای مختلف
3- مراحلی که برای ایجاد این سبکهای متنی دنبال می کنید چیست ؟

تمرین

1- از تگهای bold و italic و دیگر تگها در جملات خود استفاده کنید .


New Page 1

آموزش HTML >فصل دوم > درس 6 - < ul >, < ol > لیستها

درس 6 - < ul >, < ol > لیستها

لیستها روشهای خوب و روشنی برای بیان مطالب هستند .

اهداف این درس

1- شناسایی کدهایی برای ایجاد لیستها
2- ایجاد لیست در سند و مشاهده آن

شروع درس

خیلی از صفحات وب اقلام خود را بصورت لیستهای نقطه دار یا شماره دار نشان می دهند ، بوجودآوردن این لیستها در HTML کار آسانی است . همچنین شما می توانید لیستهای تو در تو نیز ایجاد کنید ، لیستها در جداول و فصل بندی ها نیز بسیار مهم هستند .
لیستهای نامرتب یا تگهای < ul > و < ul / > مانند لیست نقطه دار اقلام ظاهر می شوند . اینگونه لیستها نیاز به مرورگرهای خاصی برای تیتر دارند و همه نوع مرورگری آن را حمایت نمی کند .

مثال :

تگ < UL > و < UL / > به ترتیب در آغاز و پایان لیست ظاهر می شود.

لیستهای مرتب

در این لیستها اقلام بصورت مسلسل شماره گذاری می گردند و شروع آن با عدد 1 می باشد.
لیستهای تو در تو
لیستهای مرتب و نامرتب سطوح مختلفی دارند که هر کدام می توانند توسط مرور گر شما بطور مناسب اختصاص داده شوند توجه اصلی شما باید به این قضیه معطوف باشد که مشخص شود که لیست بطور مناسب پایان پذیرفته و ترتیب لیست تو در تو رعایت شود . تگهایی که در این قضیه استفاده می شود عبارتند از :
< ol > , < li > , < /ul > , < /li >

مثال :

ترکیب لیستهای تو در تو با یکدیگر

نه تنها می توانید لیستهای مرتب را با یکدیگر ترکیب کنید بلکه می توانید انواع مختلفی از لیستها را با هم ترکیب و بکار برید .

قرار دادن لیست ها در سند HTML

1- باز کردن محیط کاری
2- باز کردن سند HTML در ویرایشگر متنی
3- در زیر سر فصل آموزش از راه دور از لیستهای نامرتب برای نمایش آموزشهایی که در سایت بصورت Online داریم استفاده می کنیم
4- ابتدا جمله فوق را استفاده کنید . چندمورد از آنها را می دانید ؟
5- قالب HTML را برای ایجاد لیست اضافه کنید .

6- می توانیم از لیستهای مرتب برای تکلیف درس استفاده کنید .
7- نتایج خود را ذخیره کنید .

آزمایش

مروری بر مطالب

1- لیستها در صفحات وب چه ارزشی دارند ؟
2- تگ های HTML مرتب با لیستهای نامرتب چیست ؟
3- تک لیستهای مرتب چیست ؟
4- چگونه لیستهای تو در تو آرایش می شوند ؟
5- چه مراحلی برای اضافه کردن این لیستها ایجاد می شود؟

تمرین

در صفحه وب خود از انواع لیستهای آموزش داده شده استفاده کنید .


New Page 1

آموزش HTML >فصل دوم > درس 7 - قالب بندی فایلهای گرافیکی و استاندارد های مورد استفاده در صفحات وب

درس 7 - قالب بندی فایلهای گرافیکی و استاندارد های مورد استفاده در صفحات وب

در دهه های گذشته در صفحات وب فقط از متن استفاده می شد ، ولی امروزه از تصاویر گرافیکی استفاده می شود که در اینصورت پیام شما بسیار آموزنده خواهد بود .

اهداف این درس

1- شناسایی فایلهای گرافیکی شبکه www
2- بحث کلیدی در مورد استفاده از گرافیک در سندهای وب
3- انتقال فایل گرافیکی از وب به کامپیوتر شخصی خود
4- استفاده از قالب صحیح برای تصاویر در صفحات وب

شروع درس

همانطور كه مي دانيد تعداد بسیار زیادی از قالب بندیهای گرافیکی وجود دارند .مثل pict , hif : tiff , png حالتی که مرورگر وب گرافیکها را در شکل ، HTML نشان می دهد بیان کننده محل فایل گرافیکی در یک قالب دستوراتی است که می تواند توسط انواع مختلفی از کامپیوترها تفسیر شود .

برای مثال :

هنگامی که اطلاعات در آن قالب به کامپیوتر مکینتاش می رسد مرورگر آن را در قالب دستور برای مکینتاش نشان می دهد و برای کامپیوترهای معمولی وضع به همین منوال است.gif اطلاعات تصویر را فشرده می کند ( کاهش حجم فایل) و اطلاعات را به کدهای دودوئی قابل ارسال برروی اینترنت تبدیل می کند. gif فشرده موثر ترین فایل گرافیکی است که ناحیه یکپارچه رنگی متصل به حجمی دارد و فشردگی آن قابل تنظیم است . هنگامی که رنگ به طور متوالی در یک جهت افقی باشد فایلهای gif خاصیت شفافی دارند ، بنابراین فایلهای gif با درجه خلاصه سازی ذخیره می شوند و در صفحات وبی که از gif برای تصاویر استفاده شده ، تصاویر به زودی دیده می شوند. ابتدا تصوير به صورت تیره ظاهر مي شود تا در نهايت تصویر نهایی ظاهر گردد .
از فرصتهای دیگر تصویر jpg می باشد که مخفف کلمات Joint photo graphic expert group در اوایل شروع تصاویر jpeg در صفحه نشان داده نمی شدند و در پنجره ای جداگانه به نمایش درمی آمدند . اما مرورگرهای امروزی از فایلهای jpeg پشتیبانی می کنند و آنها را در صفحه نمایش می دهند .
اگر تنوع رنگ در فاصله کمی زیاد باشد ، برای فایلهای با قالب jpeg می توان به درجه خلاصه سازی تعریف کرد. فایلهای jpeg قابلیت تحرک و انیمیشن سازی ندارند . برای بدست آوردن اطلاعات بیشتر برای این قالب فایل به آدرس زیر مراجعه کنید .
http://www.biblio.org/notes/otis-comression.html تعداد زیادی از برنامه های گرافیکی می توانند فایل را با پسوند gif ذخیره کنند . امروزه برنامه های image ready از شرکت adobe طرح مشخصی برای ایجاد تصاویر گرافیکی دارند .
نکاتی که هنگام استفاده از تصاویر گرافیکی باید در نظر گرفت . هنگامی که در صفحه وب از عکس استفاده می کنید، به نکات زیر توجه کنید .
• تصاویر بزرگ و بیشماری که کل صفحه کامپیوتر را در بر می گیرد برای کاربری که در انتظار ظاهر شدن آن عکس می باشد ، خسته کننده می شود . پیشنهاد این است که کل سایز عکس را بیشتر از 100kb نکنید .
• همه کاربران از مانیتور 21 اینچ استفاده نمی کنند طول تصاویر بکار برده شده را بیشتر از pix 480 و عرض آنها را بیشتر از pix 300 نکنید که کاربر مجبور می شود برای دیدن تمام عکس از Scroll استفاده کند .
• شیب رنگ برای فایلهای gif ممکن است زیاد به نظر برسد اما فایلهای gif نمی توانند این ناحیه رنگ یکپارچه را فشرده کنند . بعضی برنامه های گرافیکی این اختیار را به شما می دهند كه ، هنگام برگردان فایل به gif ، لبه های تصویر هموار شود و از اختلالات تصویر کاسته شود .
بهتر است اول تصاویر کوچک استفاده شود و سپس این تصاویر به تصاویر با سایز بزرگتر اتصال پیدا کنند .
یک تصویر خاص که شما در صفحه اینترنت می بینید ، ممکن است هر بار در یک بازه زمانی ، برای شما ظاهر شود .
• بیشتراوقات ، مرورگر تصاویر را از hard disk شما cash می کنند. یعنی هنگامی که یک عکس بارگزاری می شود ،از hard شما آورده می شوند . شما ممکن است که صفحه زیبا طراحی کنید که عکسهای بزرگی در آن بار گزاری شوند اما برای یک مودم با سرعت کم و شبکه شلوغ کار مشقت باری است .

مروری بر مطالب

1- دو قالب معمول مورد استفاده تصاویر در صفحات وب چیست ؟
2- چگونه یک تصویر گرافیکی در کامپیوترهای مختلف نشان داده می شود ؟
3- نکاتی که هنگام استفاده از تصاویر وب باید در نظر گرفت چیست ؟


New Page 1

آموزش HTML >فصل دوم > درس -٧-ب - قرار دادن تصاوير در اسناد

درس -٧-ب - قرار دادن تصاوير در اسناد

اهداف این درس

1- قرار دادن تصاویر در اسناد html
2-چگونه می توان دور تا دور تصاویر متن قرار داد
3- مشخص کردن ابعاد تصاویر
4- ویرایش عکس و اضافه کردن خصلتی در آن بطوریکه بتواند در مرورگرهایی که از عکس پشتیبانی نمی کنند کارآیی داشته باشند .

شروع درس :

تگ های HTML برای تصاویر گرافیکی خطی

وقتی که نام فایل gif مانند همان نامی باشد که اسم آن فایل است و در شاخه خاصی قرار گرفته ، در اینصورت مرورگر می تواند آن تصویر را مابین متن ها نشان دهد .
برای اینکه تصویر در خط دیگری وارد شود می توان قبل از تگ تصویر یک تگ پاراگراف قرارداد .
تنظیم محل عکس به وسیله صفتی آورده می شود < IMG > شما می توانید در همجواری عکس و متن کنترل داشته باشید صفت align در تگ < IMG > این امکان را برای شما ایجاد می کند

قرار دادن تصویر در صفحه وب :

1- باز کردن محیط کاری
2- باز کردن فایل Lesson1 .html
3- در بالای < h1 / > آموزش از راه دور < h1 > تگ زیر را قرار دهید .

این قالب HTML در بالای صفحه قرار خواهد گرفت .
4- ذخیره کردن صفحه و بار گزاری مجدد .
تذکر ) در هنگام جاگذاری عکس ممکن است تعجب کنید که چرا در اینجا برای شکسته شدن پاراگراف نیاز به تگ < p > نداشتید . دلیل آن این است که مرورگر در صورت برخورد به تگ < h1 > و < h2 > و ... خود خط ایجاد می کند .

صفتALT

اگر صفحه وب شما به وسیله کاربری که با مرورگر متنی کار می کند دیده شود در اینصورت تصویر دیده نمی شود یا ممکن است کاربران برای جلوگیری ازاتلاف زمانی که در اثر بارگیری یک عکس در یک شبکه شلوغ پیش می آید از دیدن عکس صرفنظر کرده و بارگذاری را متوقف کنند در این حالت است که صفت ALT در تگ Img مفید خواهد بود . در این صفت توضیحی راجع یه عکس آورده می شود که با نگهداشتن ماوس روس عکس این صفت ظاهر می شود.
امکان دیگری که شما می توانید در تگ < img > داشته باشید صفات Height و Width می باشد با این دو صفت می توانید ابعاد یک تصویر را مشخص کنید .
< Img src=" filename.gif" width=X height=Y >
X - طول و Y عرض تصویر را مشخص می کند.
شما می توانید از یکسری از برنامه های گرافیکی سودمند برای اینکه این اعداد را تخمین بزنید استفاده کنید. روش دیگر برای پیدا کردن ابعاد عکس این است که شما می توانید آیکون مورد نظر را با Drag and Drap به پنجره مرورگر بکشید و طول و عرض تصویر در Titlebar مرورگر نشان داده می شود .

تذکر : ترتیب صفات در تگ < Img > مهم نیست .

مروری بر مطالب

1- قالب HTML برای تصاویر چیست ؟
2- برای اینکه عکس در یک پاراگراف جداگانه ظاهر شود از چه تگی استفاده می شود ؟
3- چگونه یک عکس را به صفحه خود اضافه می کنید ؟
4- صفات تگ < Img > چیست ؟

تمرین

در صفحات خود از تصویر استفاده کنید .


New Page 1

آموزش HTML >فصل سوم > درس 8 - LINK ( اتصال )

درس 8 - LINK ( اتصال )

URL- چیست ؟

قدرت واقعی وب در توانایی آن در ایجاد ابر متن هایی است که وابسته به اطلاعات است که آن اطلاعات بصورتهای صوت و عکس و ... انیمیشن در یک کامپیوتر راه دور قرار داده شده است www پهناور از یک آدرس شناخته شده بنام URL که مخفف Uniform Resource Location است برای مشخص کردن موقعیت مکان خود استفاده می کند.
این اتصالات ابرمتن معمولا با خطی در زیر آن مشخص شده اند.
a ) اتصال به یک فایل محلی

اهداف این درس

1- ایجاد یک اتصال در یک سند HTML در همان شاخه ای که سند شما قرار دارد.
2- ایجاد یک اتصال برای نمایش یک فایل گرافیکی
3- ایجاد یک اتصال در شاخه ای به جز شاخه ای که سند در آن قرار دارد.
4- سازماندهی مجدد ساختار وب شما

شروع درس

در مرحله اول شما a برای اتصال به صفحه دوم یک ابر متن ایجاد کنید این اتصال محلی نامیده می شود زیرا هر دو یک کامپیوتر مستقر هستند.

اتصال به فایلهای محلی

ساده ترین روش اتصال این است که فایل HTML دیگری که در همان شاخه سند ما قرار دارد ایجاد گردد و در صفحه وب به نمایش در آید .تگ HTML آن بصورت زیر است :

برای لنگرگاه لینک استفاده می شود و href برای ارجاع دادن ابرمتن مطلب یا عکسی که از آن به عنوان اتصال استفاده می شود بعد از بسته شدن اولین تگ و قبل از شروع < a / > قرار می گیرد . معمولا متونی که دارای اتصال هستند با خطی در زیر آنها مشخص می شوند .
حال مراحل زیر را برای ساختن یک اتصال دنبال کنید:
1- ابتدا فایل Lesson1.html را باز کنید .
2- در زیر لغت آموزش از راه دور متن زیر را وارد کنید .
"در اینجا ما سعی می کنیم شما را با بزرگترین سایتهای آموزش از راه دور آشنا کنیم و برخی از آنها را ترجمه و برای استفاده شما در سایت بکار ببریم" .
3- حال عبارات زیر را وارد کنید: در این صفحه شما طراحی صفحات وب را مطالعه خواهید کرد و ما در اینجا به
امیدواریم استفاده لازم را ببرید . جمله آموزش HTML را می توانید در یک سند HTML ثانوی با نام Lesson2.html ذخیره شده ببینید که در مراحل 5 و 6 آن را دنبال می کنیم .
4- سند خود را ذخیره کنید .
5- حال بوسیله ویرایشگر متنی یک ویرایشگر جدید باز کنید.
6- متون زیر را وارد کنید .

در اینجا بر عناوین آموزش HTML که از مهمترین آنها ساختن ابر متن ها می باشد می پردازیم :

7- این فایل را با نام Lesson2.html ذخیره کنید.
8- دوباره فایل Lesson1.html را بارگذاری کنید .
9- هنگامی که روی آموزش HTML کلیک کنید به صفحه 2 که در مورد آموزش HTML می باشد هدایت می شوید .

اتصال به یک تصویر :

در درس 7 توضیح دادیم که چگونه یک عکس خطی را در صفحه وب نمایش دهیم . با تگ anchor شما می توانید یک اتصال برای نمایش فایل گرافیکی ایجاد کنید . هنگامی که این اتصال انتخاب شود فایل گرافیکی برای نمایش فایل گرافیکی به کامپیوتر شما آورده می شود . ساده ترین روش آن است که تصویر و سند شما در یک شاخه باشند . با یک اتصال ساده بر روی یک متن فایل گرافیکی به نمایش در آید.

حال مراحل زیر را برای اضافه کردن یک اتصال به فایل گرافیکی در سند خود دنبال می کنیم :
1- یک عکس در کامپیوتر خود قرار دهید .
2- فایل Lesson2.html را باز کنید .
متن زیر را به آن اضافه کنید :
برای آموزش بهتر از یک سری تصاویر استفاده می کنیم . با دیدن
آموزش مفیدتر خواهد بود.
3- ذخیره مراحل انجام شده
4- کلیک بر روی اتصال که در مرحله 3 ایجاد شد.
5- تصویر نمایش داده می شود .

اتصال به شاخه های دیگر

نوع دیگر اتصال ، اتصال به فایل در شاخه ای به جز آن شاخه ای که سند اصلی ما در آن قرار دارد. مثلا در آموزش ما ممکن است از تصاویر پیشنهادی استفاده کنیم که همه آنها را در شاخه تصویر ذخیره می کنیم و سندهای HTML را در شاخه سند ، بنابراین در اینجا از اتصال شاخه به شاخه استفاده می کنیم .
مراحل زیر را انجام دهید :
1- در کامپیوتر خود شاخه ای به نام Picture ایجاد کنید .
2- فایل گرافیکی Lesson2.gif را به یک شاخه جدید منتقل کنید .
3- فایل Lesson2.html را در ویرایشگر خود باز کنید .
4- تگ زیر را به سند خود اضافه کنید :
5- سند خود را ذخیره کنید و دوباره بارگذاری کنید .

اتصال در شاخه های تودرتو

ممکن است برای آدرس دهی در اتصالات مجبور به استفاده از فولدرهای تو در تو شویم :
< a href ="…/…/home.html" >back to home< /a >
هر کدام از این مسیرها که با / جدا شده اند یک URL می باشند که به مرورگر برای نمایش عکس در صفحه کمک می کنند .
1- ابتدا یک فولدر با نام آموزش ایجاد کنید .
2- دو فایل HTML شناخته شده خود را به این فولدر انتقال دهید .
3- تصاویر خود به نامهای Lesson1.jpg و Lesson2.jpg را در فولدر Picture انتقال دهید. سپس فولدرهای Picture و Amozesh را به فولدر Work انتقال دهید.
4- فایل Lesson1.html را باز کنید .
5- به اتصال درون این فایل توجه کنید.

6- تگ < Img > را ویرایش کنید .

7- اعمال خود را ذخیره کنید .

یک تغییر کوچک

روش نرمال و معمولی برای ذخیره سازی اسناد این است که معمولا سند اول را با نام Index.html ذخیره می کنند پس بهتر است فایل Lesson1.html را Rename کرده و آن را با نام index.html ذخیره کنید.

چرا باید چنین کنید ؟

فرض کنید شما کار خود را به اتمام رساندید و آماده هستید تا صفحات را بصورت وب ببینید. URL سایت شما www.biqu.edu می باشد. و فایل مورد نظر شما در این شاخه ذخیره شده است : www.biqu.com /courses /geolgy /lesson1.html بنابراین URL آن عبارتست از :
http://www.biqu.edu/courses/science/geology/lesson1.html بطور معمولی نامی که برای صفحات وب بطور پیش فرض در نظر گرفته می شود index.html است .

مروری بر مطالب

1- چه مراحلی را برای ایجاد یک اتصال محلی دنبال می کنید ؟
2- چه مراحلی را برای نمایش یک عکس در پنجره جدید دنبال می کند.
3- چگونه اسناد اتصالات را در شاخه های متعدد نگهداری می کنند ؟
4- اهمیت نامگذاری index.html در چیست ؟

توضیحات اضافی

شما می توانید از این روش برای Down load کردن نرم افزارهای مختلف نیز استفاده کنید . روش انجام آن بصورت زیر است :

در صفحه وب خود از اتصالات فایلهای محلی استفاده کنید.


New Page 1

آموزش HTML

فصل اول
مقدمه
درس 1 - ایجاد اولین سند HTML
درس 2 - ویرایش یک سند HTML
درس 3 - نشانه گذاری 6 درجه
درس 4 - شکستن پاراگراف

فصل دوم
درس 5 - سبکهای مختلف نوشتاری
درس 6 - < ul >, < ol > لیستها
درس 7 - قالب بندی فایلهای گرافیکی و استاندارد های مورد استفاده در صفحات وب
درس -٧-ب - قرار دادن تصاوير در اسناد

فصل سوم
درس 8 - LINK ( اتصال )
٨-ب - لينك به سايت ديگر
٨-ج اتصال به یک سایت دیگر از اینترنت
٨-د - اتصال به قسمتی از همان صفحه
٨-ه - اتصالات ابر متن و تصویرهای لینک شده
درس 9 - به رديف در آوردن متن

فصل چهارم
درس 10 - کاراکترهای ویژه
درس 11 - لیستهای تعریف
درس 12 - آدرسهای زیر نویس و اتصالات email
درس 13 - وارد کردن یک توده متن بطوریکه از بقیه متن متمایز باشد .
درس 14 - گذاشتن بافت براي صفحه
درس 15 - عدم استفاده از تگهای blink و Marquee

فصل پنجم
درس 16 - زیبا کردن متن
درس 17 - ايجاد خط
درس 18 - Extra Alignment
درس 19 - آرایش در جدول
درس 20 - نقشه های تصویری

فصل ششم
درس 21 - Meta tag
درس 22 - پنجره Target
درس 23 - فریم کردن صفحه
درس 24 - اضافه کردن فرم به صفحات وب
درس ٢٤-ب - بوجود آوردن فرم ها
درس 25 - چند رسانه ای در صفحات شما
25 -ب - اضافه کردن فیلم و صوت -multimedia
درس 25 - ج - قالبهاي صوتي مورد استفاده

ضمیمه
معرفی منبع - تماس با نویسنده


لينكهاي روزانه

جديدترين نرم افزار macromedia

در خبرنامه استاد آن لاين عضو شويد

بازديد كنندگان

راهنماي سايت

کاربر گرامی :

از آنجا که پايه و اساس بستر مخابراتی و شرایط کیفی خطوط کاربران اینترنت اجازه امکان برگزاری آزمون همزمان از راه دور را فراهم نمی آورد ، کاربرانی که نمره بالای 75 در آزمون روی وب در هر دوره کسب می نمایند در صورت علاقه مندی می توانند در آزمون حضوری دوره مربوطه در مرکز اطلاع رسانی و تکنولوژی اطلاعات اصفهان شرکت نموده و مدرک مربوط به دوره آموزشی را کسب نمایند .

دومین آزمون سراسری سایت استاد آن لاین نیز با کاربرانی که از راههای دور و نزدیک برای شرکت در آزمون حضوری و اخذ مدرک طلایی ممهور به مهر IT گرد هم آمده بودند در مرکز تکنولوژی اطلاعات اصفهان برگزار شد. سومین آزمون سراسری عملی این سایت در تاریخ 30/2/1383 انجام می گردد،لذا از خانمها و آقایانی که در این مدت توسط پست الکترونیک با آنها مکاتبه خواهد شد دعوت می شود،خانمها راس ساعت 2 بعد از ظهر تاریخ اعلام شده و آقایان راس ساعت 9 صبح با در دست داشتن کارت شناسایی معتبر عکس دار به پذیرش مرکز اطلاع رسانی و تکنولوژی اطلاعات اصفهان مراجعه نمایند.بدیهی است عدم حضور شما در تاریخ مقرر به منزله انصراف تلقی می گردد.

گروه تخصصی آموزش مجازی (ostadonline)


لينكهاي روزانه

جديدترين نرم افزار macromedia

در خبرنامه استاد آن لاين عضو شويد

بازديد كنندگان

مقالات


لينكهاي روزانه

جديدترين نرم افزار macromedia

در خبرنامه استاد آن لاين عضو شويد

بازديد كنندگان

كتابهاي الکترونیکی

eBooks Information Technology Center

  • Active X
  • Information Technology Basic
  • Adobe Photoshop 6.0
  • Windows 98

eBooks

  • Active Server Pages 3.0.PDF
  • ATM Switch Router Command Reference.PDF
  • Cisco CCIE Fundamentals Network Design.PDF
  • Delphi 6 Developer's Guide.PDF
  • Delphi 6 QuickStart.PDF
  • Dial Solutions Quick Configuration Guide.PDF
  • Dial Solutions Quick Configuration Guide 2.PDF
  • Dictionary of Networking.PDF
  • HDD.PDF
  • Installing a Second Operating System.PDF
  • Internetworking Case Studies.PDF
  • Internetworking Technology Overview.PDF
  • Internetworking Terms and Acronyms.PDF
  • Intrusion Detection Planning Guide.PDF
  • Object Pascal Language Guide.PDF
  • Oracle Candidate Certification Guide.PDF
  • Oracle8 Candidate Certification Guide.PDF
  • Overview of Access VPNs.PDF
  • PartitionMagic.PDF
  • PartitionMagic Pro Scripting.PDF
  • Print Server.PDF
  • PrintSir User’s Manual.PDF
  • Router Security.PDF
  • TCP IP Cheatsheet.PDF


لينكهاي روزانه

جديدترين نرم افزار macromedia

در خبرنامه استاد آن لاين عضو شويد

بازديد كنندگان

یاد گیری الکترونیکی

در حال حاضر انقلاب تكنولوژي عميقاً نحوه تفكر عمل و بسياري از فرآيندهاي كاري را در زندگي ما تغيير داده است . تحولات بزرگ جامعه بشري ، ما را به سويي مي كشاند كه آموزش مجازی امري اجتناب ناپذير خواهد شد و گاهاً ميتوان در اين عرصه فرصتهايي را يافت كه نتيجه فرآيند آموزش را غني تر نموده و چه بسا با در اختيار گرفتن امكانات كمك آموزشي ديداري و شنيداري پيشرفته در اين نوع آموزش ، دروس و ارائه مطالب را بسيار جذاب تر كرد .

درهر حال مركز اطلاع رساني و تكنولوژي اطلاعات اصفهان بعنوان اولين و بزرگترين مركز تحقيقات و آموزش تكنولوژي اطلاعات در استان بر آن است تا با غني سازي سايت تخصصي آموزش مجازی بتواند گامي مؤثر در استفاده از فن آوري روز ، آموزش و متعاقباً توسعه آموزشهاي مجازي در آموزش هاي فني و حرفه اي بردارد .

آنچه لازم به ذكر است مشكلات و چالشهايي است كه در توسعه آموزش مجازی در پيش رو داريم . امكانات كاربران آموزشها در جامعه بواسطه استفاده از پهناي باند محدود آنها و نيز ساير محدوديتهاي مخابراتي و تجهيزات رايانه اي هنوز عوامل محدوديت زا در توسعه و بهينه كردن آموزش از راه دور و ارائه اين نوع آموزش در شكل پيشرفته ميباشد .

اميد است در آينده نزديك با رفع موانع ، شرايطي فراهم گردد تا بتوانيم به شكل مدرن به آموزش مجازي از طريق اينترنت بپردازيم . آنچه امروز در سايت تخصصي آموزش مجازی قابل استفاده است تعدادي دوره آموزش است كه با محتواي مطلوب و به شكل مناسب ارائه ميگردد . در آينده نزديك كليه مطالب در دوره هاي مختلف آزمون گذاري خواهند شد و نيز هر دو هفته يكبار به تعداد دوره هاي آموزش در زمينه هاي مختلف افزوده ميگردد .

ضروريست از زحماتواحد توسعه و آموزش مجازی IT اين مركز و همچنين مدرسين دوره هاي ارائه شده نهايت امتنان بعمل آيد .


لينكهاي روزانه

جديدترين نرم افزار macromedia

در خبرنامه استاد آن لاين عضو شويد

بازديد كنندگان

پرسش و پاسخ

*

نام

*

پست الكترونيكي

بله خير

آيا تا كنون مدركي از اين سايت دريافت نمودهايد ؟

*

پرسش خود را مطرح كنيد ؟

* پركردن قسمتهاي ستاره دار الزامي است

دسته بندي مورد نظر خود را انتخاب نمائيد
گرافيك | طراحي وب
برنامه نويسي | مجموعه افيس
شبكه | ICDL
 | متفرقه


لينكهاي روزانه

جديدترين نرم افزار macromedia

در خبرنامه استاد آن لاين عضو شويد

بازديد كنندگان

سايتهاي مرتبط

  • www.w3schools.com
  • www.schoolnet.ir


لينكهاي روزانه

جديدترين نرم افزار macromedia

در خبرنامه استاد آن لاين عضو شويد

بازديد كنندگان

كار آموزان برتر

ü کاربرانی که در آزمون نمره بالای 75 کسب نمایند در این قسمت از سایت معرفی می گردند .

ü توجه : کاربران محترم به دليل ارسال E-mail هاي گروهي ، سايت Yahoo ، مكاتبات الكترونيكي استاد آن لاين را در صندوق Bulk شما ذخيره مي نمايد . خواهشمنديم در صورت عضويت در سايت Yahoo و شركت در آزمون استاد آن لاين پاسخ مكاتبات خود را در صندوق bulk خود پيگيري فرماييد .

ü توجه : از كاربران گرامي خواهشمنديم بدليل خوانايي بيشتر ، هنگام تكميل فرم مخصوص آزمون ، نام و نام خانوادگي و مشخصات خود را بصورت لاتين وارد نمايند ، بديهي است در غير اينصورت در صورت ناخوانا بودن هر يك از مشخصات ، حتي با كسب نمره ي قبولي از درج نام و نام خانوادگي ، در ليست كارآموزان برتر معذوريم ...

براي ديدن كارآموزاني كه موفق به دريافت مدرك شده اند اينجا را كليك كنيد

كارآموزاني كه در آزمونها نمرات بالا كسب نموده اند

نمره | شهر | دوره انتخابی | نام
80 of 100 | تهران | Word | مريم ابراهيمي
75 of 100 | تهران | مفاهيم پايه فن آوري اطلاعات | مريم ابراهيمي
100 of 100 ***** | همدان | CIW | امير حيدري
95 of 100 | همدان | Java & Active-x | امير حيدري
75 of 100 | بندرعباس | Word | احمد جليلي
85 of 100 | اصفهان | فتوشاپ | زهره منتظري
75 of 100 | لرستان | ويندوز 98 | جلال حميدي
100 OF 100 **** | اصفهان | اينترنت | محمدرضا مقاره عابد
80 of 100 | اصفهان | Word | محمدرضا شيخ سجاديه
100 of 100 **** | تهران | ويندوز 98 | مهدي شريفي
100 of 100 **** | اصفهان | Word | محمدرضا نويد پور
75 of 100 | اصفهان | فتوشاپ | ميلاد اعتباريان
90 of 100 | اصفهان | اينترنت | محمدرضا نويدپور
70 of 100 | اصفهان | اينترنت | محمدجواد زماني فر
80 of 100 | اصفهان | اينترنت | حسين پورعباسي
95 of 100 | اصفهان | Word | حسين پور عباسي
80 of 100 | تهران | Word | علي زادسر
80 of 100 | اصفهان | اينترنت | نيلوفر دهقان
80 of 100 | -------- | ويندوز 98 | مهديه مولايي
100 of 100 **** | اصفهان | CIW | مازيار دهقان
75 of 100 | اصفهان | آشنايي با مفاهيم و اصطلاحات اينترنتي | مازيار دهقان
100 of 100 **** | اصفهان | ويندوز 98 | مريم زندي
95 of 100 | اصفهان | مفاهيم پايه فن آوري اطلاعات | مريم زندي
80 of 100 | اصفهان | Word | محمدرضا نويد پور
80 of 100 | اصفهان | مفاهيم پايه فن آوري اطلاعات | حسين پورعباسي
90 of 100 | اصفهان | مفاهيم پايه فن آوري اطلاعات | محمدرضا نويد پور
95 of 100 | اهواز | مفاهيم پايه فن آوري اطلاعات | قاسم حسودپور
75 of 100 | اهواز | اينترنت | قاسم حسودپور
90 of 100 | تهران | ويندوز 98 | رحمت اله اميرصوفي
100 of 100 **** | تهران | مفاهيم پايه فن آوري اطلاعات | رحمت اله اميرصوفي
100 of 100 **** | تهران | اينترنت | رحمت اله اميرصوفي
100 of 100 **** | تهران | آشنايي با مفاهيم و اصطلاحات اينترنتي | رحمت اله اميرصوفي
80 of 100 | اصفهان | فتوشاپ | فاتحه جليلي
80 of 100 | اصفهان | Word | مرتضي جولايي
85 of 100 | -------- | اينترنت | فتاحي
80 of 100 | -------- | ويندوز 98 | فتاحي
85 of 100 | تهران | فتوشاپ | شعبان شريعتي
80 of 100 | تهران | ويندوز 98 | شعبان شريعتي
75 of 100 | اصفهان | اينترنت | بتول نورافشان
90 of 100 | اصفهان | آشنايي با مفاهيم و اصطلاحات اينترنتي | رضا ترابي
80 of 100 | اصفهان | Word | مرتضي جولايي
75 of 100 | ------ | ويندوز 98 | نادر فاضل
80 of 100 | تهران | ويندوز 98 | مليسا سلطاني
75 of 100 | تهران | فتوشاپ | مليسا سلطاني
90 of 100 | تهران | مفاهيم پايه فن آوري اطلاعات | رحمت اله اميريوسفي
75 of 100 | اصفهان | ويندوز 98 | رضا ترابي
70 of 100 | تهران | مفاهيم پايه فن آوري اطلاعات | ابراهيم داروغه زاده
80 of 100 | -------- | Word | زهره جمالي
95 of 100 | رشت | اينترنت | حميرا احمد فرد
100 of 100 **** | اصفهان | مفاهيم پايه فن آوري اطلاعات | رضا ترابي
80 of 100 | اصفهان | ويندوز 98 | محمدرضا شيخ سجادي
100 of 100 **** | رشت | اينترنت | فرامرز جعفرنيا
90 of 100 | اصفهان | فتوشاپ | عماد اعتباريان
80 of 100 | تهران | ويندوز 98 | سيد رسول حسيني
85 OF 100 | شاهين شهر | Word | نجمه شهبازي
80 of 100 | تهران | مفاهيم پايه فن آوري اطلاعات | داداش تبار
75 of 100 | شيراز | فتوشاپ | رضا عبدالهي
75 of 100 | اصفهان | مفاهيم پايه فن آوري اطلاعات | مازيار دهقان
80 of 100 | اصفهان | اينترنت | مازيار دهقان
75 of 100 | ساري | فتوشاپ | رضا جمشيدي
85 of 100 | اصفهان | فتوشاپ | مجتبي پنجه علي دخت
80 of 100 | ------ | اينترنت | محمد مهدي اديب بهروز
75 of 100 | مشهد | مفاهيم پايه فن آوري اطلاعات | حسن غلامي
85 of 100 | اصفهان | Word | حاج زرگرباشي
75 of 100 | شهركرد | آموزش فتوشاپ | مختاري فرد
75 of 100 | اصفهان | ويندوز 98 | حاج زرگر باشي
95 of 100 | مشهد | مفاهيم پايه فن آوري اطلاعات | سعيد باجوري
80 of 100 | اصفهان | مفاهيم پايه فن آوري اطلاعات | وحيد بلوچستاني اصل
75 of 100 | ------- | مفاهيم پايه فن آوري اطلاعات | محسن مدرس
75 of 100 | ملاير | آشنايي با مفاهيم و اصطلاحات اينترنتي | بهنام كرماني
95 of 100 | تهران | ويندوز 98 | فاطمه ميلاني
90 of 100 | تهران | فتوشاپ | مجتبي عبدالرحيم خان
85 of 100 | اصفهان | ويندوز 98 | رضا ترابي
80 of 100 | اصفهان | مفاهيم پايه فن آوري اطلاعات | علي ابراهيمي
80 of 100 | اصفهان | مفاهيم پايه فن آوري اطلاعات | سامان ثابت راسخ
80 of 100 | مشهد | ويندوز 98 | علي موحدي
75 of 100 | كرج | Word | حسين توكلي
85 of 100 | كرج | ويندوز 98 | حسين توكلي
85 of 100 | كرج | مفايهم پايه فن آوري اطلاعات | حسين توكلي
90 of 100 | ايالات متحده آمريكا | ويندوز 98 | ارشك اسكندريان
95 of 100 | اصفهان | Word | ابراهيم معصومي
95 of 100 | -------- | فتوشاپ | زهرا
90 | اصفهان | آموزش فتوشاپ | بهار
85 OF 100 | تهران | مفايهم پايه فن آوري اطلاعات | مريم يوسفي
85 of 100 | سنندج | مفاهيم پايه فن آوري اطلاعات | رامين
85 of 100 | تهران | مفاهيم پايه فن آوري اطلاعات | مريم يوسفي
90 of 100 | ------ | آموزش اينترنت | فرناز اميدي
80 of 100 | گرگان | مفاهيم پايه فن آوري اطلاعات | پرژك چلواري نصرتي
75 of 100 | شاهين شهر | مهارتهاي رفتاري | صادق شهبازي
75 of 100 | ------- | آموزش اينترنت | حسام خان راماكي
75 of 100 | ------- | آموزش اينترنت | حسام خان راماكي
100 of 100 **** | قزوين | مفاهيم پايه فن آوري اطلاعات | فرزان كريمي
80 of 100 | ------ | Word | راحيل
85 of 100 | ------ | آموزش اينترنت | راحيل
85 of 100 | قزوين | آشنايي با مفاهيم و اصطلاحات اينترنتي | فرزان كريمي
80 of 100 | قزوين | Word | فرزان كريمي
80 of 100 | ------- | آموزش اينترنت | حسين كهن
80 of 100 | قزوين | مهارت هاي رفتاري | فرزان كريمي
90 of 100 | قزوين | Win 98 | فرزان كريمي
75 of 100 | قزوين | آموزش اينترنت | فرزان كريمي
80 of 100 | قزوين | مفاهيم پايه فن آوري اطلاعات | فرزان كريمي
80 of 100 | -------- | آموزش اينترنت | احمدي
75 of 100 | كاشان | Word | زينب شايسته
85 of 100 | -------- | win98 | عبداله ميرقائد
75 of 100 | اصفهان | win 98 | شهشهاني
80 of 100 | -------- | مفاهيم پايه فن آوري اطلاعات | صادق كيان
85 of 100 | ساري | مفاهيم پايه فن آوري اطلاعات | اكبر قربانزاده
80 of 100 | -------- | Word | محمود
100 of 100*** | -------- | آشنايي با مفاهيم و اصطلاحات اينترنتي | جواد مداري
80 of 100 | --------- | مفاهيم پايه فناوري اطلاعات | صفورا
95 of 100 | --------- | win98 | صفورا
80 of 100 | --------- | word | صفورا
80 of 100 | تهران | word | رضا كاظم زاده
85 of 100 | مراغه | فتوشاپ | پيروز رحماني
75 of 100 | ---- | word | سعادتي
80 of 100


لينكهاي روزانه

جديدترين نرم افزار macromedia

در خبرنامه استاد آن لاين عضو شويد

بازديد كنندگان

كار آموزان برتر

ü کاربرانی که در آزمون نمره بالای 75 کسب نمایند در این قسمت از سایت معرفی می گردند .

ü توجه : کاربران محترم به دليل ارسال E-mail هاي گروهي ، سايت Yahoo ، مكاتبات الكترونيكي استاد آن لاين را در صندوق Bulk شما ذخيره مي نمايد . خواهشمنديم در صورت عضويت در سايت Yahoo و شركت در آزمون استاد آن لاين پاسخ مكاتبات خود را در صندوق bulk خود پيگيري فرماييد .

ü توجه: در صورتيكه مشخص گردد كاربري در آزمون يك دوره ي آموزشي دوبار شركت كرده و آنرا با پست الكترونيكي ارسال نموده باشد، چنانچه نمره ي قبولي را هم كسب كرده باشد از شركت در آزمون حضوري معاف خواهد شد،پس خواهشمنديم براي هر دوره ي آموزشي فقط يكبار آزمون بدهيد .

ü توجه : بنا به رعايت ننمودن برخي كاربران براي شركت در آزمون دوره هاي مختلف لازم است به اطلاع برسانيم از تاريخ 16/3/84 به بعد ، كاربران محترم فقط مجاز به شركت در دو آزمون مي باشند . بديهي است به تعداد بيش از دو آزمون ترتيب اثر داده نخواهد شد .

ü توجه : از كاربران گرامي خواهشمنديم بدليل خوانايي بيشتر ، هنگام تكميل فرم مخصوص آزمون ، نام و نام خانوادگي و مشخصات خود را بصورت لاتين وارد نمايند ، بديهي است در غير اينصورت در صورت ناخوانا بودن هر يك از مشخصات ، حتي با كسب نمره ي قبولي از درج نام و نام خانوادگي ، در ليست كارآموزان برتر معذوريم .

براي ديدن كارآموزاني كه موفق به دريافت مدرك شده اند اينجا را كليك كنيد

كارآموزاني كه در آزمونها نمرات بالا كسب نموده اند

نمره | شهر | دوره انتخابی | نام
80 of 100 | تهران | ويندوز 98 | آرش سعادت نيا
80 of 100 | تهران | مفاهيم پايه فن آوري اطلاعات | آرش سعادت نيا
85 of 100 | اراك | فتوشاپ | سيد وحيد حيدري
80 of 100 | اصفهان | Access | رضا ولي خواني
100 of 100**** | تهران | Java,Active-X | مريم علي نژاد
95 of 100 | اصفهان | powerpoint | هما فولادزاده
80 of 100 | تهران | Excel | امير حاجي عبدالرزاقي
80 of 100 | مباركه | Flash MX | علي مومن زاده
90 of 100 | اصفهان | word | شراره شيراني
85 of 100 | اصفهان | html | احمد رضا ملك محمدي
85 of 100 | اصفهان | Excel | سميرا ذهبيون
100 of 100 **** | زرين شهر | html | مهدي سليمان
80 of 100 | شاهين شهر | مفاهيم پايه فن آوري اطلاعات | سعيد صفرا فرد
85 of 100 | رشت | مفايهم پايه فن آوري اطلاعات | محمد رضا شعباني
85 of 100 | اصفهان | مفاهيم و اصطلاحات اينترنتي | محمد ترابي
90 of 100 | اصفهان | Excel | شراره شيراني
100 of 100 | اصفهان | فتوشاپ | نوشين بهشتي


لينكهاي روزانه

جديدترين نرم افزار macromedia

در خبرنامه استاد آن لاين عضو شويد

بازديد كنندگان

مدرسين

پست الکترونیکی | تخصص ها | نام مربی
bzarabian@etvto.ir | CIW - HTML - Internet | بیتا ضرابیان
amortazavi@etvto.ir | MCSE-NETWORK+-A+ | امير حسين مرتضوي
hasani@etvto.ir | Photoshop - Freehand | فاطمه حسنی
arefi@etvto.ir | flash-html | ریحانه عارفی مقدم
ebrahimzadeh@etvto.ir | ASP - ADO | نوشین ابراهیم زاده
seifollahi@etvto.ir | SQL - Javascript | مهدی سیف الهی
zarei@etvto.ir | Word ( Office Software ) | ویدا زارعی
sedaghatkish@etvto.ir | office-flash | مديا صداقت كيش
gholshani@etvto.ir | internet-network | مهرداد گلشنی
mosberian@etvto.ir | Web Design-Graphist | مازیار مصبریان تنها
 | graphist-office | آرش رضا پورخان
malali@etvto.ir | flash-office | مهشید ملالی
 | Office Software | فرهاد زارع


Easy CHM - Create your first CHM help or CHM ebook files in 10 seconds with Easy CHM

This CHM was compiled by an UNREGISTERED version of Easy CHM.
Registered version doesn't compile this page into CHM!

Easy CHM - Ver: 1.95 Written by: GuohuaSoft |  | Screen Shot ASP Member=
Release Date: 10/26/2004 Release Status: New Release | File Size: 1392k - 1.39MB | Type: Shareware Cost: US $35
Keywords: make chm, create chm, chm converter, html2chm, htm2chm, txt2chm, generate chm, chm maker, convert chm, create microsoft html,help, generate html help, help file generator, chm creation tool, create compressed html-help

Description:
Create your first CHM help or CHM ebook files in 10 seconds with Easy CHM.

Key features:

  • Make CHM (Html Help) file by import folders and all sub folders.

  • Automatically generate TOC and Index Item by parsing from title/filename/text of a specificed line.

  • Easy to use TOC edior support 'Search and replace in TOC items'.

  • Convert htm/html/mht/picture and other files to CHM.

  • Plenty of customized options.
Contact Info:

Via Web:

Zipghost website: http://www.zipghost.com

eTextWizard website: http://www.etextwizard.com

Via E-mail:

webmaster@etextwizard.com
Order Online:

https://www.qwerks.com/order/buynow.asp?ProductID=7297

Download URLs:
Supported Operating Systems: Win98,WinME,WinXP,Windows2000
System Requirements:
Install Support: Install and Uninstall